ZHA regulary dies after 2021.3 update

I have ZHA working together with sonoff zigbee gateway (tasmotized, updated to 9.3.1 and with latest zigbee firmware).

What happens is that after 2021.3 update (currently on 2021.3.3) my ZHA module breaks after about 24 hours of working normaly (I do not know exactly how long or when it breaks but I know that after I come home from work it does nor respond).

Problem is not my zigbee gateway, if I restart it nothing happens. When I reload ZHA module then everything start working once again.

Now, I have repeated this three days in a row and I am confident it will happen tomorrow again; it is just that I do not know what/where to look in order to better define the problem?

p.s. this did not happen before on previous hassio versions, it started with 2021.3 update

Same here :frowning:
Not 24 hours but still…
Will monitor further, stupidly made a restart so no preserved logs.
Best, JR

I guess it is less than 24 hours. It is basically that I have restarted ZHA at about 17h and it did not work next day when I came home (three days in a row).

I do not know exact time when it failed because I was not at home during the day (but I know it worked correctly in the morning), so it happened sometime between 8-9 in the morning and 17h in the afternoon.


I am looking at my log file and first I noticed that I can pinpoint time when my zigbee devices stopped working by log entry where my entities became unavalible. Every day (last three days) this happened, time frame was different (one day at 2:10pm, second at 1:13om, third/today 4:48pm; the time from reloading zha to the moment when my devices became unavaliable are not the same).

Now, I have about 40 devices and it appears that they started dropping out over a longer period of time (from the first “unavaliable” to the last I have about 40 minutes).

I do not know what this means, but if someone can figure something out I would be grateful (or ideas on what to try).

I the same problem but it has been there for longer than last update unfortunately… I have tried everything i can think of. I am about to throw ZHA in the bin but i really love this application.

I get a message in the logs: no response to command.aps.data.indication - and the network dies :frowning:

Have you guys logged a bug on GitHub? This forum won’t get the issue solved if it’s something wrong with the HA / ZHA code, you need to submit a PR on GitHub.

Thanks Dave - Nice of you to point it out!

I submitted an issue to Github: https://github.com/home-assistant/core/issues/47982


I did a little bit more research and while it is not conclusive I have some half-clues.

  • I noticed that when I log in into my tasmota zigbee bridge I had a lot of NTP errors (I forgot to write them down but along the lines NTP not responded), this is likely timing issue and I rechecked and reconfigured my LAN NTP setup (system works for 36hours now without a problem, I will check later today if it still works), I did play with NTP in recent days because I was trying to resolve one other issue (not ZHA related) so this might be connected somehow
  • tasmota gave another update for zigbee bridge which I applied, do not know if this have any relation to my problem
  • I noticed that when I try to give zigbee command from hassio I get small notification in my lower left corner of the screen along the lines that “app controller is not running”, this error is not visible in my logbook (and do not know where to find it, it shows up for a second or so and I do not have enough time to copy&paste content or make screenshot); google search did not find any response which seem relatable to the problem

p.s. I did not submit bug because I do not know how to reproduce the problem or at least explain exactly where it happens; this issue is still to “broad” (in my mind) to warrant bug report (and in the end, it might not be a bug at all)

some more info, my ZHA died once again today (after almost 48 hours of continuous work)

when I try to press some of my buttons (on my dashboard) I get this error:

I have restarted my sonoff bridge (nothing happened) and then reloaded ZHA integration and my lights came back to life.

Not had an issue for last 3 days but I use an automation for service ZHA Network Map: scan_now every hour :frowning:
Nasty way but it updates my ZB network map at least :slight_smile:
Best, JR
BTW it would be nice to have way to reload ZHA via automations (via monitoring the weakest link e.g.)