ZHA remove old coordinator

I i have the following problem. I’ve tried the migration of my zigbee tasmota Sonoff zigbee bridge following the video of Everything Smart Home.
After that all my device where put to off and i didn’t get them active again.
After that i have completely removed ZHA from HA and rebooted.
Next reinstalled the new SonOff Zigbee 3.0 USB stick en rebooted my HA and reinstalled ZHA.
HA kept all the old zigbee devices and i needed to remove them. After that i rebind all devices one by one and all seems to work. Only i keep seeing the old bridge in de list with zigbee devices and can’t seem to remove it. Also when i view the visual representation of my zigbee network it also shows all devices connected to the old bridge and not the new one.
Does anybody know how to remove the old bridge and renew the zigbee network view.

1 Like

I have the same issue. I changed my Zigbee coordinator from older CC2531 USB Zigbee coordinator to latest Zigbee 3.0 USB coordinator both from Sonoff. All devices seems to work fine so far (except illuminance from aqara sensors, which is known issue) however in visualisation page the devices are shown connected to both, which is confusing as well as worrying. Maybe someone will discover a remedy for this. There should be a way to completely remove old coordinator.

I have cleared my complete zha integration bij manually removing all items from the devices with the action zha.remove. It’s in developer section and then services (my screenshot is dutch)

There you can remove the coordinator from the zha integration. Don’t know if you need to completely clean all devices (which i did). But now all is working like expected for me.


Good suggestion. I will try try that in spare time.

I was able to do this by also using the zha.remove service. Prior to executing the service, I validated that there were no devices using the coordinator to be removed (I had already reset all devices and migrated them to the new coordinator. I had also disconnected the old coordinator from the USB). Looks like it worked.

I had the same problem with my old Silicon labs EZSP and your solution solved my problem. Thanks