[ZHA, Skyconnect] Ikea Shortcut Button detected, but not working

Hi, today I received some Ikea devices. Shortcut buttons, on/off switch and a Styrbar remote control N2.

The on/off switch and the remote control work ootb with ZHA and Sykconnect, but I can’t get the Shortcut Buttons to work. I can pair them with ZHA, Interview and initialisation (green box) look ok. They are shown as “TRADFRI SHORTCUT Button von IKEA of Sweden”. But in the Log they are immediately “unknown”. I see the battery and the identify entities, but I don’t get any events in the log if I press the button.

They work with deCONZ and Conbee II (events are fired, no battery state), but I want to get rid of Phoscon and move to ZHA completely.

Is this a known issue? is it possible to fix this?

1 Like

Did you manage to get this working? I have same issue runnig Home Assistant 2023.8.2

Well, yeah… kinda. Not sure how, but I tried multiple Times and now it works.

I’m currently moving to a new server with Zigbee2Mqtt instead of ZHA. I hope that I have fewer issues.