ZHA / Sonoff Zigbee 3.0 USB Dongle Plus / No RSSI values

My Zigbee network with about 90 devices blew up after upgrading to 2022.4. Having had previous similar issues and having been told that ConBee II users often suffer from similar issues, I decided it was time to ditch it. I move all my devices to a Sonoff Zigbee 3.0 USB Dongle Plus and… things aren’t quite normal.

I’ve been monitoring the devices using the awesome zha-network-card and have seen devices going offline. Some come back by pressing reconfigure device, others seem to need to be reset and included again.

I also noticed that none of my devices are reporting an RSSI value. All of them did with the ConBee II. Assuming the Sonoff coordinator is also capable of reporting RSSI, how do I fix this?

Some sensors do not report LQI either… One of them, an old Smartthings Leak sensor, I included twice already since the migration to the new coordinator. I never had these issues with the ConBee II other than network blow-ups that could sometimes be resolved by unplug ConBee II, plug back in, and reboot HA…

I don’t recall having many low LQI numbers before. If I recall correctly, the higher the number the better. Maybe routing is suboptimal at this time…

Maybe I am still suffering from ZHA issues in 2022.4.x.

my understanding is that it might take a a week or so for the nesh to sort out. What i read to do is shut down HA, unplug sonoff usb fo 20mins, then plug back in and turn back on. its supposed to help with the mesh network

Yeah, I believe it causes all devices to go in panic mode trying to find a route to the coordinator. I guess it won’t hurt, I hope :wink: to try that too…

i do this every month or so

1 Like

as for the rssi, none of the texas instrument usb coordinators have them

1 Like

Ah, great, it helps to know there isn’t some bug/issue with my setup. One less thing to worry about. I guess LQI should be enough to just the health of the link.

have you got a usb extension for the coordinator?
I found that also adding all the powered devices first followed by the battery devices helped… i think lol

The coordinator is connected via an extension and is on a magnetic base on top of the rack. I know it is not ideal for it to be on top of a metal cabinet but the ConBee worked great there and didn’t even have the large antenna.

As for including, yes I worked my way from this room out doing only mains powered devices. Then I went back to include the battery ones.

1 Like

solid setup! lol, i just have a pi4 lol


I started on a Pi4 but got fed up with how long it took to reboot, load stuff, etc and I was in heavy development / setup mode so I ended up getting a 2nd hand Lenovo m920q with an i7 8700 and 32GB of RAM + 1TB SSD. I created a VM for HA using Proxmox and run a few other lightweight things on it. I guess I went a bit overkill.

1 Like

I also ditched Conbee during the 2022.4 issues and got a Sonoff 3.0. Was curious about RSSI as well so thanks for posting this! It also took a few hours for battery stats to show, but they’re here now.

I’m having issues with a couple of Aqara motion sensors being less than perfectly stable. I think I may need to pair them throw a Hue light that’s closer than the coordinator. Standard LQI for my network is in the low 100s range for battery-powered devices, and the two with issues are in the 60-80 range. Guessing that’s not a coincidence.

My only powered Zigbee devices are two Ikea bulbs and one Hue bulb. I have other Hue bulbs, but keep them on my Hue Bridge on a channel far away from ZHA.

Tip is to buy a few “IKEA Tradfri Signal Repeaters” Zigbee router devices to act as core for the network.

Then re-pair your battery-operated devices with them (and the routers) at their final locations as some battery-operated devices have a tendency not to switch to any other Zigbee router other than the one that they was initially paired with, even if you later add and place better routers closer to their location.

For more tips see https://github.com/home-assistant/home-assistant.io/commit/970295a277e8f01d3ee39eeeaacf453625b988d3 from https://github.com/home-assistant/home-assistant.io/pull/18864

Also follow best practices when pairing/re-pairing → https://www.home-assistant.io/integrations/zha#best-practices-to-avoid-pairingconnection-difficulties

I think you’re right that I could benefit from some routers. For now, I used USB extensions to move my Sonoff 3.0 out of the closet (that also is home to my WiFi router on a very-far-away channel) and stability has dramatically improved.

Super weird because when I was using deCONZ with my Conbee II right next to my WiFi router everything was fine… usually.

@benblb I wonder whether the better antenna is partially to blame… The higher gain antenna on the Sonoff allows the signal to go further (at same output) and to receive weaker signals. This sounds all great but it is a bit unbalanced when the other end is a device with a way less performant antenna.

I am guessing that devices may opt to pair with the coordinator as they receive its strong signal instead of using a router nearby, but then they struggle to be heard by the coordinator even with its better antenna. By moving it outside of the closet, the signal strength of the zigbee devices will be stronger.

Of course, putting it further away from the router, and USB 3.0 port interference obviously helps but I am suspecting it is not the only factor. I too moved from ConBee II to the Sonoff and am having issues I did not have before. I would really like to figure out what channel my coordinator is on, and what output gain it is set at. I would then want to try to reduce the output gain by 1 or 2 dBm to see if anything improves but for this test to be effective I likely also have to force all devices to find new routes (coordinator signal will be lower so they may pick alternative which might also receive them better) which may require re-pairing for battery devices - ugh!

How do you pair though another device??

Open the desired routing device, and select add device via this device option

yeah right, i always seen that

If i view the children, i have a whole bunch but i never added that via the the current device. Pls the LQI’s are way better when i look at the children

All very common. I tried to cover it in https://github.com/home-assistant/home-assistant.io/pull/18864

Please consider giving that PR a thumbs up in hope that the devs will review it and merge to ZHA docs.