ZHA, Sonoff Zigbee bridge doesn't work well

Tags: #<Tag:0x00007f326344d8c8> #<Tag:0x00007f326344e020> #<Tag:0x00007f32634d3e00>

Hi,
I have a fresh Sonoff Zigbee bridge, flashed with tasmota and the firmware for zigbee, i have set up ZHA and tried to pair 3 different Xiaomi battery devices and honestly it was a real pain, took me maybe more than 50 tries before i got them paired. I don’t know what the cause can be. I already have a deConz network at home which is big and is running but i want to evaluate Sonoff zigbee bridge. The other network should not interfere and they should be able to coexist side by side but the fact is that the pairing is very hard. The problem is that the devices don’t show up until i try many many times. Anyone else experience this ?

/donnib

Xiaomi/Aqara are somehow funny when pairing :frowning:
After pairing request I myself press sensor button every ca. 5 sec to extend timeout and not let sensor to standby- and it works OK, first ones ages ago where pain until I figured out :slight_smile:
Hope this helps, JR

@Foxxy so maybe that is what i accidentally did and succeeded. Is this a 100% recipe ? I mean have you concluded that if you do following it always work :

  1. Click add device in Hass
  2. Hold down the button on the xiaomi sensor to put it into pairing mode
  3. Click the pair button on the sensor every 5 sec until the sensor shows up in Hass

Yep, so it worked for me :slight_smile:
And of course You can use service zha_permit under Developer Tools and extend time from default 60 secs.
Best, JR

1 Like