ZHA: Still doesn't work? (Conbee III)

Bought a Conbee III a few months back, initially tried it with ZHA, didn’t work, even after spending a few hours on it.

Tried deconz docker instead, setup and working just fine (and using the HA deconz add-on).

Today I setup HAOS on a new microSD card (currently running Rasbian + Deconz docker), same issue (ZHA sits there at “Loading next step for zha”). Tried importing current network, failed. Power cycled everything, tried new network, which did reset the stick but still failed to load correctly (i.e. I couldn’t get to the point where I could add devices). Followed the various google searches with people having similar issues with no success.

Firmware on the Conbee was updated when purchased, about 3 months ago.

Why does the Conbee III work perfectly with the deconz docker but plainly refuses to work with ZHA on the exact same Pi?

Is there some magic step I need to do to make this work?

Trying to move Home Assistant + Node-Red off my server as dockers onto a dedicate HA RPI4, but need to get this Conbee III working with ZHA!


You need make sure you uninstall/remove deconz first. You can’t have 2 zigbee instances connecting to the same coordinator

I don’t, I have two microSD cards setup.

One has rasbian + deconz

New one has HAOS on it.

Obviously only booting from one card at a time.

Ah, missed the fact that it’s a Conbee 3, not 2. Did you check whether support for this coordinator has been added to ZHA?

I have a Conbee3 and it works fine with ZHA on a RPi4. Only thing was that I had to use USB2 and an extension cord to get it working. I did end up using Zigbee2MQTT instead though.

Using HAOS?

Might have to try and update the firmware to reset the stick and try again.

Already using USB2 ports and a USB EXT (and it works just fine with recons…!)

Yes, using HAOS. I did update the stick to latest firmware (0x26500900) - don’t know if that makes a difference.

There was a some Conbee III compatibility issues introduced in 2024.1.6, but it should have been fixed: