ZHA stuck. How to restart the integration?

After power outage HA rebooted but the ZHA stuck with an error and there is no option to restart just this integration. All zigbee devices not working…
Z2Mqtt addon could be rebooted but this integration runs w/o this option… crazy… HA restart does not help ZHA start with the same error…

Logger: homeassistant.components.zha.core.gateway
Source: components/zha/core/gateway.py:152
Integration: Zigbee Home Automation (documentation, issues)
First occurred: 3:16:06 PM (5 occurrences)
Last logged: 3:20:53 PM

Couldn't start ZNP = Texas Instruments Z-Stack ZNP protocol: CC253x, CC26x2, CC13x2 coordinator
Traceback (most recent call last):
  File "/usr/local/lib/python3.9/site-packages/zigpy_znp/api.py", line 395, in request
    response = await response_future

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/zha/core/gateway.py", line 152, in async_initialize
    self.application_controller = await app_controller_cls.new(
  File "/usr/local/lib/python3.9/site-packages/zigpy/application.py", line 69, in new
    await app.startup(auto_form)
  File "/usr/local/lib/python3.9/site-packages/zigpy_znp/zigbee/application.py", line 196, in startup
    return await self._startup(
  File "/usr/local/lib/python3.9/site-packages/zigpy_znp/zigbee/application.py", line 209, in _startup
    await znp.connect()
  File "/usr/local/lib/python3.9/site-packages/zigpy_znp/api.py", line 119, in connect
    await self.nvram.determine_alignment()
  File "/usr/local/lib/python3.9/site-packages/zigpy_znp/nvram.py", line 35, in determine_alignment
    value = await self.osal_read(nvids.OsalNvIds.NWKKEY, item_type=t.Bytes)
  File "/usr/local/lib/python3.9/site-packages/zigpy_znp/nvram.py", line 170, in osal_read
    length = (await self.znp.request(c.SYS.OSALNVLength.Req(Id=nv_id))).ItemLen
  File "/usr/local/lib/python3.9/site-packages/zigpy_znp/api.py", line 395, in request
    response = await response_future
  File "/usr/local/lib/python3.9/site-packages/async_timeout/__init__.py", line 55, in __aexit__
  File "/usr/local/lib/python3.9/site-packages/async_timeout/__init__.py", line 92, in _do_exit
    raise asyncio.TimeoutError

one more error

Logger: zigpy_znp.api
Source: /usr/local/lib/python3.9/site-packages/zigpy_znp/api.py:267
First occurred: 3:25:31 PM (46 occurrences)
Last logged: 3:55:06 PM

Received an unhandled command: SYS.ResetInd.Callback(Reason=<ResetReason.PowerUp: 0>, TransportRev=2, ProductId=1, MajorRel=2, MinorRel=7, MaintRel=1)
Received an unhandled command: SYS.OSALNVReadExt.Rsp(Status=<Status.SUCCESS: 0>, Value=b'\x55')
Received an unhandled command: ZDO.StateChangeInd.Callback(State=<DeviceState.StartedAsCoordinator: 9>)
Received an unhandled command: AppConfig.BDBCommissioningNotification.Callback(Status=<BDBCommissioningStatus.NetworkRestored: 13>, Mode=<BDBCommissioningMode.NONE: 0>, RemainingModes=<BDBCommissioningMode.NwkFormation: 4>)
Received an unhandled command: ZDO.MgmtPermitJoinReq.Rsp(Status=<Status.NWK_INVALID_REQUEST: 194>)

What stick are you using ?

slae.sh usb stick in usb2 port . it is on a 1meter cable

Try taking it out and plugging it back in.

tried… no luck.
rebooted HA a few times - no dice…
Then wanted to upgrade SW to the latest release (because I am still on 9.3), start a backup and it failed with ‘Unknown error’ (literally ) and HA rebooted itself. I waited for a few minutes and it did not start, then removed power cable manually… and now ZHA works again…

I really do not like it. seems only complete power off makes it stuck and then helps…

Running from a SD ?

no, on SSD, it is on USB3…

But it is not the end… after ZHA took back the control and all seems worked again… now it fails again. the option ‘Reload’ is back for the ZHA integration. but once I pressed it it asked ’ Restart Home Assistant to finish reloading this integration’ … WTF! it like a quiz… haha … all errors are back in the log…

Ooops… I found my zigbee2mqtt addon started automatically as well…
stop it and reload ZHA… so far no issue…

You can’t use zigbee2mqtt and ZHA at the same time with the same stick. One of the two will throw errors.

yes, right. I am kinda piloting ZHA now, that is why left z2m installed (forgot to switch off ‘autostart’ option) But for ZHA would be good to check if device is allocated by another process (is it possible in linux?)