ZHA won't work after restoring backup

Hi everyone!

Last Saturday night I bricked my home-assistant install while experimenting a bit. Being the good Samaritan I am, I had 30 days of backups so I went and restored the last known working backup.

Everything restored perfectly except for some fiddling around with the domain and duckdns and my dashboard fired up perfectly.

That’s when I noticed my ZHA devices where not showing up.

I got the same error as this user https://github.com/home-assistant/core/issues/52777, but fixed that error with the help of this comment https://github.com/home-assistant/core/issues/52777#issuecomment-877495278 but with the right version information (so just copying zha to the custom_components folder.

After that that error was fixed but my Zigbee network was still not coming online. I disabled DeconZ since I thought that might have been interfering (was not using it) but that also didn’t do the trick.

I tried deleting the integration to re-install it but I can’t. I can only disable and enable it.

I’m kind of out of options short of starting from scratch again but I’d rather not since that’s allot of work. Help would be greatly appreciated.

Here is the log I get when I start up.

Logger: homeassistant.setup
Source: setup.py:162
First occurred: 07:17:08 (1 occurrences)
Last logged: 07:17:08

Setup failed for custom integration zha: Unable to import component: cannot import name 'filter_supported_color_modes' from 'homeassistant.components.light' (/usr/src/homeassistant/homeassistant/components/light/__init__.py)

And after that a related message

Logger: homeassistant.config_entries
Source: config_entries.py:745
First occurred: 07:17:27 (2 occurrences)
Last logged: 07:17:27

Error occurred loading configuration flow for integration zha: cannot import name 'filter_supported_color_modes' from 'homeassistant.components.light' (/usr/src/homeassistant/homeassistant/components/light/__init__.py)