ZHA: Yale YRD210 - getting UNSUP_CLUSTER_COMMAND when calling get_pin_code

Hello everyone,

Here is the problem. I am getting UNSUP_CLUSTER_COMMAND when I try to call get_pin_code function to pull pin code from the lock using cluster command. It may be related to Yale quirks
that doesn’t fully support those (though this assumption might be wrong).


service: zha.issue_zigbee_cluster_command
  ieee: 00:0d:6f:00:02:XX:XX:XX
  endpoint_id: 1
  cluster_id: 257
  command: 6
  command_type: server
    user_id: 2


2022-12-05 11:55:35.193 ERROR (MainThread) [homeassistant.helpers.script.websocket_api_script] websocket_api script: Error executing script. Error for call_service at pos 1: Failed to issue cluster command with status: <Status.UNSUP_CLUSTER_COMMAND: 129>
2022-12-05 11:55:35.194 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection] [140258940105776] Error handling message: Failed to issue cluster command with status: <Status.UNSUP_CLUSTER_COMMAND: 129> (unknown_error) from (Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:102.0) Gecko/20100101 Firefox/102.0)

Yale Zigbee Home Automation Profile (page 8) says:

Yale RealLiving quirks - note that the reference to input_clusters doesn’t include 0x05 or 0x06 commands, that I am trying to use:

class YRD210PBDB220TSLL(CustomDevice):
    """Yale YRD210 PB BP and Yale YRL220 TS LL Locks."""

    signature = {
        #  <SimpleDescriptor endpoint=1 profile=260 device_type=10
        #  device_version=0
        #  input_clusters=[0, 1, 3, 9, 10, 257, 32]
        #  output_clusters=[10, 25]>

I also tried to use zha_custom_quirks, but was not able to figure out what exactly is needed to allow those commands. :frowning: Would appreciate any help.

No one to suggest anything?

@VladStar Did you ever figure this out?

I just bought the Z-Wave version, but cannot figure out how to manage the user PINs from HA.

@info4hx4 Just tested the same ZHA query with HA version 2023.10.5 - still getting exactly the same error :frowning:

The PINs cannot be managed on the Yale YRD210-ZW-605 (Z-Wave).

Z-Wave connection was established without any issues.

Returned. :sob: