ZHA Zigbee firmware update fails

I am trying to update the firmware of a NodOn SIN-4-2-20 Switch. When I search for updates, I get this displayed

When I click install (installieren), I get this error message:

Any help available how to do this correctly and make it work?

Not a helpful answer, but it took about 20 tries over two HASS releases to update my IKEA RODRET 2-button remote control.

Experiments with moving the battery remote next to the coordinator, rebooting, restarting ZHA, all made no difference.

In the end, it “just worked” without special actions, so my guess is there’s some sort of conflict or race condition that just needs luck to avoid.

(The remote is next to a IKEA mains plug repeater, with a reasonably dense mesh.)

I’ve seen this with my Third Reality motion sensors, usually it’s only twice I need to do it. (One oddball time it failed over and over because I had changed channels and the device would only scan 15.) Is it battery powered? I think those go into some sort of a sleep state to conserve battery until they are triggered, so they don’t ever see the signal over the network.

Thanks for the hints. I still get the message and cannot update NodOn firmware.