ZHA - ZigPy - Thermostatic valve TS0601 doesn't work

Hello,
I’m using ZHA with ZigPy, i hope i’m in the good category !

I bought a Tuya thermostatic valve (TS0601) and I would like to pair it with my Pizigate, but it doesn’t work very well…
The pair is ok, but i can’t read anything, and ZigPy doesn’t create any entity.

I put the verbose mode, this is the log of HA :
http://pastebin.fr/73875

This is my “ZigBee informations” in ZHA :
http://pastebin.fr/73877

I’ll also search, I’ll keep you informed.

Thanks !

I have same issue. No entity is created for the TRV.
Iam using sonoff zigbee bridge with tasmota using the this tutorial

Maybe we should create entity manually but as iam starting with HA iam not sure where to begin.
Maybe its tasmota zigbee firmware issue?

@Kalypox did you fixed it?

Hi !

I found here the quirks for the valve, but I don’t know how integrate it in ZHA.
Valve.py
It’s around line 168.

Maybe someone could help us ?

Hello,

@cyberium Yes, here : https://github.com/zigpy/zha-device-handlers/pull/538

@EggEek You just have to copy/paste the zhaquirks folder :wink:
See the readme : https://github.com/zigpy/zha-device-handlersµ

And don’t forget to modify your manifest.json of zha in homeassistant core like that :
image
Else the zhaquirks-dev doesn’t works

1 Like

@Kalypox Thank you very much for pointing me in the right direction.

I gained access to the zhaquirks folders using portainer addons. Maybe there is better way to do that.

  • install portainer addon
  • unhide homeassistant container
  • access the console using portainer access
  • you can now, using samba share or any other way to download this folder and put it in config folder
  • next step is only to overwrite “/usr/local/lib/python3.8/site-packages/zhaquirks/” with downloaded files.
  • restart

I didn’t had to change the manifest.
Battery seem to not work.

Target temp seem to not work too. Something is not correct about the update of the climate card. When new target temp is choosen it took some minutes for the card to be updated even if TRV is updated.

Hi @cyberium,

The battery doesn’t work on my TS0601 too.
And your method is good, but it depends of each installation.
I have a raspberrypi with raspbian + docker-compose and a lot of containers (including portainer, to manage them):


And in my case, i just mounted a volume from my docker to my host to access core and zhaquirks:
image
If I use the dev:

I have errors and i have to edit: /usr/src/homeassistant/homeassistant\core\components\zha\manifest.json to update versions

Have a nice day !!

EDIT:

Something is not correct about the update of the climate card. When new target temp is choosen it took some minutes for the card to be updated even if TRV is updated.

Yes I have a lot of bugs too, but it works
image
I added a xiaomi temperature sensor to see:
image

1 Like

On my side it’s not working. I have updated the zhaquirks folder but when i try to integrate the TRV I don’t have any entity :frowning:

Capture d’écran du 2020-12-13 17-29-55

I’m running HA in a VM (with ProxMox), so I don’t know if everything is similar. It’s look like the zhaquirks folder is not taking in account when zha detect the TRV.

Hi @EggEek,

Enable logging in HA : “zhaquirks.tuya: debug”, remove the device, and post the log here when you pair the valve. I can’t help you without the log.
You should have something like that:

[0xbcc6:1] Manufacturer: _TZE200_ckud7u2l
[0xbcc6:1] Model: TS0601
Checking quirks for _TZE200_ckud7u2l TS0601 (bc:33:ac:ff:fe:63:fb:1e)
Considering <class 'zhaquirks.tuya.valve.MoesBHT'>

Here is my log from ZHA when I try to add the TRV :

ZHA Log

I have those entries :

[0x4898:1] Manufacturer: _TZE200_ckud7u2l
[0x4898:1] Model: TS0601
Checking quirks for _TZE200_ckud7u2l TS0601 (60:a4:23:ff:fe:ab:49:5c)
Considering <class 'zhaquirks.tuya.electric_heating.MoesBHT'>

So I think that the wrong quirks is chosen by HA… It’s not an eletric heating device… Maybe I need to add only the needed quirks and not all. I’m completely lost in this integration, all other one was so simple :cry:

I have a similar issue with my Aqara Cube, which is not recognized correctly. I think that my quirks is not taking in account at all.

@EggEek,
It’s a bug because the quirk is selected with the manufacturer.
Remove the “zhaquirks” folder, paste a clean zhaquirks downloaded from github (or remove _pycache from existing folder)

And delete "tuya/electric_heating.py"
And restart.
Normaly, it works :wink:

Et voilà, it’s working well ! I just see that the files are back when I restart the docker container, so I have remove the file electric_heating.py and add the thermostat again.

I also have been able to add the Aqara cube !

Thanks a lot @Kalypox and @cyberium for your help !

@EggEek @cyberium

For your information, i just switched to Zigbee2MQTT this afternoon to try it.
It’s really better.
For exemple, i have a lot of informations about the valve:


The battery, the valve position, the signal strength, the childlock, the window mode, the thermostat works better, there is many modes : image

(fuyez zha ^^)
A bon entendeur :wink:

1 Like

Look awsome and promising for ZHA. I already saw that zigbee2MQTT seem more reactive than ZHA but ZHA have the advantage to be already included to HA and i dont feel the need to add another layer to those valves for now. Iam hopping that its a matter of weeks to see ZHA fill the gab for that hardware.

Thanks you very much for your advise @Kalypox.