Zigbee button missing double press and hold

I have two of these exact same buttons….ZG-101ZL

Both using Z2mqtt. The first one I installed has single, double, hold and some other functions which I don’t need.

This button, the problematic one “button.bathroom” has only the single action available. I removed and re-setup in z2mqtt. Still the same. Compared all parameters in z2mqtt and the buttons “seem” to be exactly the same except for their network address.

What could it be

The first one I setup

look at the operation mode

thanks. bother were set to ‘event’. i tried switching the offending button from to ‘command’ and then back to ‘event’ but no change

now it’s fixed.
the solution: leave it alone. it took a few hours but i came back to check (after i had reintroduced it to zigbee controller) and all of the operations/actions are now available.

That reminds me something I forgot to mention - sometimes Z2M doesn’t seem to know about a double press until you actually generate a double click on the button.

1 Like