Zigbee can't find device

I see this error message in the Zigbee Home Automation integration:

Failed setup, will retry: [Errno 2] could not open port /dev/serial/by-id/usb-ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2_20221130103229-if00: [Errno 2] No such file or directory: '/dev/serial/by-id/usb-ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2_20221130103229-if00'

Everything was working fine. I didn’t update anything and it just stopped working at 11am yesterday.

I plugged the USB dongle into another linux box (a pop os 22.04 laptop) and it showed up fine in dmesg:

[173616.683827] usb 3- new full-speed USB device number 12 using xhci_hcd
[173616.842664] usb 3- New USB device found, idVendor=1a86, idProduct=55d4, bcdDevice= 4.42
[173616.842679] usb 3- New USB device strings: Mfr=1, Product=2, SerialNumber=3
[173616.842685] usb 3- Product: SONOFF Zigbee 3.0 USB Dongle Plus V2
[173616.842688] usb 3- Manufacturer: ITEAD
[173616.842692] usb 3- SerialNumber: 20221130103229
[173616.852685] cdc_acm 3- ttyACM0: USB ACM device

And it was in the right place (on the laptop):


I tried looking at the device in the home assistant terminal, but it is just that pseudo docker terminal in the add-ons. It doesn’t see anything in lsusb and it looks like the device stuff is all container stuff.

What steps should I take to debug it?

How do you run HA ?

I have a home assistant blue. So HAOS?

The Blue are known for developing faulty USB ports :frowning: Is the dongle directly connected to the Blue?

1 Like

That would be a bummer. It is connected through a USB extension cord.

I tried the second port.

Let’s see… What else can I try to connect and confirm the USB port is broken or working…

Any chance you have a USB hub laying around that you can plug into the Blue? Perhaps there is a power shortage that you can compensate with a powered hub. I always use a powered hub with all my HA dongles, a lesson learned with similar failures back when I used an rPi 4B.

USB hub didn’t work. I have a home lab machine running portainer. I suppose I have to migrate to that or replace the odroid.

We might have had some kind of power surge, although the timestamps don’t line up right with this issue.

I also have an electronics workbench. I could rework the 5V regulator.

The chassi/enclosure walls of the Home Assistant Blue are very thick due to poor design that makes the USB-ports sunken, therefore the USB-plug on some dongles like those (and other USB-devices/peripherals) are known to be too short so do not make proper physical contact when plugged into the Home Assistant Blue, so the workaround is to use a USB extension cable (which you should use regardless) that has a longer USB-plug to make sure it makes proper physical contact (i.e. that it can be plugged in all the way despite the thick chassi/enclosure walls of the Home Assistant Blue ). I mention this under tips here → ITead’s “Sonoff Zigbee 3.0 USB Dongle Plus V2” (model "ZBDongle-E") based on Silicon Labs EFR32MG21 +20dBm radio SoC/MCU

To avoid EMF interference strongly recommended buy and use → Long USB extension cable

  • Another reason for using a USB extension cable is that the USB-plug design of ITead’s Sonoff Zigbee 3.0 USB dongle hardware adapters is a little short which makes it harder and sometimes impossible to plug it into some USB ports if the computer enclosure/chassis/casing is to thick around the USB-port as that will physically prevent the USB dongle from actually making a proper connection inside the USB port even if it looks like it is plugged in all the way that is possible.
    • Some people than have taken a Dremel, power-drill or other power-tool to physically modify the Home Assistant Blue chassi/enclosure to fix the issue of sunken USB-ports, see: image
  • Also follow all the general tips in https://github.com/zigpy/zigpy/wiki/Generic-best-practice-tips-on-improving-Zigbee-network-range-and-general-stability as all Zigbee Coordinator adapters is very sensitive to EMI/RFI interference (e.g. a noisy radio frequency environment will jam the signal and prevent it from receiving all Zigbee messages to it without errors). Connecting the dongle via a long “shielded” USB extension cable in a USB 2.0 port or USB 2.0 hub (and not a USB 3.0 port) to get it away from EMF sources will usually help a lot if experiencing connection or pairing symptoms/issues.

Thanks Hedda. But I have been using an extension so far. It randomly quit working while still plugged in and the extension and dongle are still working on a regular Linux laptop. So the idea that the 5V regulator on the Blue makes sense to me.