Zigbee Config - Docker Access to USB Stick

Alright - I admit - I made a dumb mistake. I am posting this solely because when I looked I couldn’t find the answer I was looking for (which was simple). Maybe this will help someone else.

I run HA on an Ubuntu PC insider a Docker container, and use Docker Compose. I recently purchased a Nortek Gocontrol HUSBZB-1 stick to add a zigbee and z-wave networks to my HA. But like many people, I could not get HA to find the zigbee stick. There are lots of pages out there with sample docker-compose files for this scenario. I tried them, restarted my pc, but no matter what I did HA could not find the USB stick.

Finally, it dawned on me: maybe instead of restarting my PC, I needed to rebuild my docker container. I tried that and … Presto! No problem. All works. For anyone who is interested, Here is the docker-compose file that worked:

version: '3'
services:
  homeassistant:
    container_name: home-assistant
    image: homeassistant/home-assistant:stable
    volumes:
      - /hass/config:/config
      - /etc/localtime:/etc/localtime:ro
      - /dev/serial/by-id:/dev/serial/by-id
    devices:
      - /dev/ttyUSB0:/dev/ttyUSB0
      - /dev/ttyUSB1:/dev/ttyUSB1
    environment:
      - TZ=America/Los_Angeles
    restart: always
    network_mode: host

After saving that file, I ran the following (which updates HA and rebuilds);

sudo docker-compose pull
sudo docker-compose up -d --build homeassistant

Hope that helps someone else.

18 Likes

You saved my day!

Fantastic. Absolutely useful information.

Adding the following commands to help identify locations.

  • Details of USB devices: sudo usb-devices
  • Summary of USB devices: sudo lsusb
  • Show USB devices by ID: sudo ls -la /dev/serial/by-id
2 Likes

Helped me today!