Zigbee Connection Problems (cc2531)

HI there!

RPI4 with ssd
HA Version 0.112.4
cc2531 usb zigbee stick with external antenna

since sunday i have trouble with my zigbee network, to turn on my lights.
i have no clue where to look for, since nothing has changed and it suddenly stopped working.
zigbee2mqtt i use, the log says this:

zigbee2mqtt:error 2020-07-28 20:20:43: Publish 'set' 'state' to 'Inbouwspot Keuken 3' failed: 'Error: Command 0x14b457fffe2d8ee2/1 genOnOff.on({}, {"timeout":10000,"disableResponse":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (Timeout - 47478 - 1 - 222 - 6 - 11 after 10000ms)'
zigbee2mqtt:info  2020-07-28 20:20:43: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"type":"zigbee_publish_error","message":"Publish 'set' 'state' to 'Inbouwspot Keuken 3' failed: 'Error: Command 0x14b457fffe2d8ee2/1 genOnOff.on({}, {\"timeout\":10000,\"disableResponse\":false,\"disableDefaultResponse\":false,\"direction\":0,\"srcEndpoint\":null,\"reservedBits\":0,\"manufacturerCode\":null,\"transactionSequenceNumber\":null}) failed (Timeout - 47478 - 1 - 222 - 6 - 11 after 10000ms)'","meta":{"friendly_name":"Inbouwspot Keuken 3"}}'

i don’t know where to start looking, since its not a clear error message, for me at least

Signal quality must be good, since it was good when it still worked, and what i want to power on over the network are routers also.

This one down is an in-wall switch, used to work good also, i do think this is the cause, i can power it on manually on the wall, but no state change in HA or the zigbee log

zigbee2mqtt:info  2020-07-28 20:26:55: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"type":"zigbee_publish_error","message":"Publish 'set' 'state' to 'Eettafel' failed: 'Error: Command 0xec1bbdfffe803b85/1 genOnOff.on({}, {\"timeout\":10000,\"disableResponse\":false,\"disableDefaultResponse\":false,\"direction\":0,\"srcEndpoint\":null,\"reservedBits\":0,\"manufacturerCode\":null,\"transactionSequenceNumber\":null}) failed (Timeout - 61936 - 1 - 6 - 6 - 11 after 10000ms)'","meta":{"friendly_name":"Eettafel"}}'

Can you point me in a direction? thanks!

Did you try rebooting your Pi?

I’m sorry, yes i surely did. at least, rebooted HA, thats the same i guess or is there a difference in the complete pi?


i do see a lot of these log treads, dont know if this hold things back?


rebooting HA does not reset your CC2531. Rebooting your Pi does.

I did reboot the entire thing after your post.
Did help slightly, since 8/10 lights now do come on quickly. But still 2 who wouldnt cooperate. 1 of them a router.

I had nothing but problems with my cc2531 running zigbee2mqtt. Once i hit about 10 devices, the whole thing was just flakey. It would be fine for days, and then crap for a day or so, and then good for a week, on constant repeat.

About a month ago i replaced it with a LAUNCHXL-CC26X2R1 and all my problems went away. I mostly went with that as it was the only thing i could find that was stocked locally (in Australia) and given the current world state getting things shipped here internationally is somewhat difficult,.

You can see your other options here.

Thanks for your reply,

i will keep that in mind, for now it is fixed.

i tried to pair the devices again (wich was easyier than i tought, since all the settings stay, i was worried to change all my HA entities and so on.

while i was doing that (so the coordinator accepted new connections) the rest also came back to life… si i think it has something to do with that connection, needed a new one or something.

if it happens again i will try the accept incoming connections switch first.