Zigbee Connectivity in my house sucks 😢

I get it, but ignoring the guidance you’re given because you want to rush it just makes it harder on yourself, and things will take longer :wink: As the saying goes slow is smooth, and smooth is fast.

1 Like

I just wanted to drop a note here about what worked for me. I have been following this thread because the logs have been screaming at me since I started using ZHA that my channel is around 95%-96% utilized. I was not having as many problems as the OP, but I was having to occasionally re-pair devices or retry API calls. I did what several posters have suggested (Download diagnostics) and saw that all of the usual channels were chuck full (>90%). In the end, I needed to do two things:

  1. My Wifi router (Asus ZenWifi AX) was configured to use a 40MHz bandwidth for the 2.4GHz range, even though the benefits of widening it beyond 20MHz are dubious at best.
  2. When I narrowed that down to the normal 20MHz, suddenly Zigbee channel 20 was showing lots of room in the spectrum. I switched from channel 15 to 20. I had to re-pair a couple of battery-powered devices, but it mostly just worked.

When I restarted, ZHA complained about the settings being changed, but I just clicked the “Keep these new settings” button (I forget the exact wording) and it was happy.

No more warnings in the logs and I’ve stopped seeing those messages in the logs about failing to deliver messages.

I hope that helps someone!

Edit: grammar.

3 Likes

Zigbee can be made easier if you first put a little effort into understanding its limitations (e.i. extremely sensitive to interference, + relative poor reception and low power transmissions on a high frequency) so I do suggest you read enough about it to grasp the concept of its mesh networking technology enough to know how to work around its quirks (i.e. relying on having many Zigbee Router devices to extend range and coverage).

It could also be easy by chance for some simply because they just so happen to start by adding loads of mains-powered Zigbee products that act as Zigbee Router devices and coincidently not place any device close to sources of EMF/EMI/RMI interference, and only after that added Zigbee End Devices (line battery-powered producs).

Personally, I do however not believe in that naive approach, and instead think that researching first before buying anything will give me less of a headache later.

Again, I highly recommend you read and follow this before troubleshooting deeper:

also suggest reading these community guides as well to some gain basic Zigbee knowledge:

2 Likes

@Hedda , I think you write some helpful and knowledgable posts about Zigbee, however I think a statement such as :

“Zigbee … its limitations (e.i. extremely sensitive to interference, poor reception)”

is quite the opposite.

To blanket say that a device in the Zigbee universe is any more susceptible to “interference” and have bad “reception” is not a true statement.

A discussion on this could go on for many :beer::beer:s.

I will just ask, how can a device that can be built on the same piece of hardware that runs, Zigbee, Bluetooth, WiFi or other 2.4 Ghz 802 protocol just with a change in firmware be as you say “sensitive to interference, poor reception” with one firmware vs. another. All are using the same physical and lower level firmware for their same radios?

Sure argue that different approaches to power profiles of a device, especially a battery powered one can effect a universe, however again you can make any of the firmwares I point to suck, if you are not well versed in the design. But that is very different than saying Zigbee is going to be worse than one of the others just because it is Zigbee.

1 Like

Ooop. Staying out of this one… :worried:

In other words zigbee has only around 1/4 of the range of wifi and tends to be at least 4 times as sensitive to interference.

Just asking for a friend, you got an electrical engineering degree based on google research such as this?

To much wine again on a Wednesday David…

1 Like

It is whine wednesday, the day after taco tuesday :wink:

Haha, guys, don’t hijack my thread :grin:

I switched the zigbee channel. The aqara motion sensor worked fine for some time, then stopped… See screenshot of the lqi below:


i

The channel is set to 25, see another screenshot below:

I think I might setup another Pi from scratch, attach the skyconnect, pair the always-on devices and see what happens… Maybe some configuration is broken on the original Pi

Does the device work and report in when its triggered?
Some of the devices will sleep after a certain amount of time not triggered.
Dont get too caught up in that chart, youll never get past it.
as long as the device works and reports in when triggered, youre fine.

Well it stopped working the same time. Last time the sensor triggered was 9pm yesterday, and we walked past it quite often after that.

The screenshot is only semi useful this time :see_no_evil:

It says that it reseted 14 hours ago to “no motion detected”.that’s 9pm yesterday as of writing this

Quick note that I read all the mentioned guides :hugs:

I did this to and also improved some things but in the end I weren’t able to get all my zigbee stuff working reliable despite having a router for battery powered devices at maximum 4 or 5 meters away.

Long story short: Sold all of my zigbee gear and went for esphome wifi devices. After a little on boarding (getting used to esphome) all of my 50 esphome nodes do work since the day installed and perform fantastically. Some esphome devices have a clear advantage over zigbee stuff (no lagging, real time updates) others “just” work rock solid no matter what (also very refreshing after waisting money and to much time with zigbee).

1 Like

Esphome… That’s exclusively self-made, right? I’m not very proficient in soldering and all that flashing devices… I did at some point order a esp8… Which is no lying around somewhere.

I’m at a point where I would rather spent 30€ on a working motion sensor than spending 10 hours to solder and flash stuff :see_no_evil:

All/most zigbee devices show lost connection now, even the mains powered ones:

Motion sensor:

Power socket:

No. I bought most of my stuff (plugs, etc.) with esphome already pre-installed (e.g. from https://athom.tech/esphome). If they also have bluetooth (like esp32 based devices) they can be auto discovered (and provisioned for your wifi) directly in/from HA

Oh boy, whole new world. Enlightening! I have to think about that. Thanks mate!

Not sure if this requires a new thread:

I bought a pre-flashed Sonoff/tasmota zigbee bridge to test things from there.

I’m trying to find a guide on how to set this up, but not finding a good guide. They all explain how to flash it, but bit how to proceed. They all say I should start a server on port 8888, but it fails for me.

Also, I’d like the bridge to act as a standalone coordinator where I can connect my devices to, and HA to request and send info to the bridge instead of the bridge act like an ordinary coordinator. Is that possible? This page here confused me a bit at the end: Home Assistant, Tasmota, and the Sonoff Zigbee Bridge | by werner | Medium

Does anyone know a good guide in this?

Well, then the bridge would be acting like “an ordinary coordinator”.

Sadly the ZBBridge is pretty much the second worst option out there. The only way you could have bought worse would have been to buy something based on the CC253x chipsets.

Buy some wired network connected coordinator supported natively by ZHA and you’ll have a much better time, and no need for complicated guides on configuring them will be needed.

Tube does some great ones, but there’s others out there too.

PS: This probably should have been a new thread, with a more relevant title, to make it more likely people would see it and help you.

1 Like