Zigbee device has sensor value not available as entity

First of all I’m fairly new to home assistant so I’m still learning a lot.

I have just installed a zigbee 3.0 motion detector which has a light sensor. It’s added to my zigbee2mqtt set up but it’s missing the illuminance level from entities. I’ve removed it and added it back several times but the illuminance is still not showing up as an entity.

The illuminance value does display when I look at the device on the zigbee2mqtt dashboard and it shows up in the state.json under config in YAML:

"0xa********5e6b758": {

        "occupancy": false,

        "illuminance": 2660,

        "battery": 100,

        "illuminance_interval": 5,

        "keep_time": "10",

        "sensitivity": "high",

        "linkquality": 180

    }

Is there another way to extract this value to use in home assistant if it doesn’t show up as an entity? I thinking it has something to do with setting up a sensor in YAML.

First check on your device if it is not a disabled entity. (the +1 entity not shown)

Doh!
Yes that was the issue. It was not enabled but there. Now it’s working. Thanks!

Screenshot Illuminance