Zigbee devices wont pair after migrating from ZHA to Zigbee2MQTT

I’ve migrated from ZHA to Zigbee2MQTT, however I can’t get any my devices to pair at all and I’m not sure what’s going wrong?

I’m using a Sonoff ZBBridge which I’ve flashed with Tasmota I followed the Digital Blur guide and went back and followed the guide to make sure the Bridge is setup correctly with a TCP 8888 port exposed.

I’ve noticed if I set the module to Sonoff ZbBridge (75) and then I use the Permit Join button on the Tasmota GUI, I’m able to pair a device in a few seconds without any issues. However, setting the module to ZHA (0) as suggested in the DigiBlur guide, the pairing inside the Z2M addon doesn’t produce any resutls.

I’m using Z2M 1.24.0-1 via the Hassio (core-2022.3.2/OS 7.4) Addon and the log from Z2M addon doesn’t seem to show anything noticeable that’s going wrong.

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] socat.sh: executing...
[14:39:35] INFO: Socat not enabled, marking service as down
[cont-init.d] socat.sh: exited 0.
[cont-init.d] zigbee2mqtt.sh: executing...
[14:39:36] INFO: MQTT available, fetching server detail ...
[14:39:36] INFO: MQTT server settings not configured, trying to auto-discovering ...
[14:39:37] INFO: Configuring 'mqtt://core-mosquitto:1883' mqtt server
[14:39:37] INFO: MQTT credentials not configured, trying to auto-discovering ...
[14:39:37] INFO: Configuring'addons' mqtt user
[14:39:37] INFO: Previous config file found, checking backup
[14:39:37] INFO: Creating backup config in '/config/zigbee2mqtt/.configuration.yaml.bk'
[14:39:37] INFO: Adjusting Zigbee2mqtt core yaml config with add-on quirks ...
[cont-init.d] zigbee2mqtt.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[14:39:38] INFO: Handing over control to Zigbee2mqtt Core ...
> [email protected] start
> node index.js
data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
  base_topic: zigbee2mqtt
  port: tcp://192.168.X.X:8888
  adapter: ezsp
  log_level: warn
  pan_id: 6754
  channel: 11
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
  port: 8099
experimental: {}
availability: false
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: '-d -d'
  log: false