Zigbee dongle in docker

Hi all, I’m trying to pass though a zigbee stick to HA via docker, The stick shows up in device manger on windows. But when I run
ls -l /dev/serial/by-id

all it shows is this. ls: cannot access ‘/dev/serial/by-id’: No such file or directory
any help would be great.

That’s not possible on Windows.

So how can you use ZHA in HA core.

Don’t use Docker on Windows? That’s not a supported installation method. If you want to run on Windows, you’d need to use a VM with a hypervisor (VMWare Fusion Player, VirtualBox, etc).

Im running Ubuntu on windows with WSL

Docker in WSL still doesn’t support host networking (yet), so that’s not supported.

1 Like

What vm would you recommend?

VMWare Workstation is a good choice if you have to run on Windows.

VirtualBox is mostly fine, though some people have problems with USB passthrough.

Both can have problems if you’re using WiFi rather than wired networking - not all Windows WiFi drivers support bridged networks.

Not running on Windows would be the best solution.

1 Like

Im already running HA on proxmox on a intel Nuc which is rock solid just noisy.
I have a massive pc which i built so i would like it all on one machine.

And to learn something else
Also my cat is not dead.

1 Like