Zigbee failure

I upgraded to 0.87 and then to 0.87.1, but had the same problem with both. I’m using a HUSBZB-1 stick and it worked fine before the upgrade, but after, I had delayed or no service on Zigbee devices. To be clear, I only have 4 Sengled bulbs in the mix right now - no other zigbee devices.

The only solution I found that worked was to comment out “discovery:” in my configuration. That seems to have solved the problem for now. Any other thoughts on what the problem could be or a better solution?

I put in a bug yesterday for similar sounding issues.


I also have a HUSBZB-1 stick

I’ve got the same set up as you (4 Sengled bulbs on the HUSBZB-1 Stick) and just upgraded to V87.0 yesterday and everything is working fine for me.

The differences might be that I’m running non-hassio in Docker on a NUC.

I did not have issues until I upgraded to 87.1. 87.0 seemed fine.

Good to know.

Getting more weird errors. It seems to take much longer to restart than with the previous version. I’m back to the same errors, even with the discovery change. The Pi takes much longer to restart now and much longer to load data once started. Sometimes the connection resets itself. The log is full of updates to media players taking longer than expected.

I noticed I also have a new Hass.io system generated user created.

Finally, the system health shows hassio as false. Is that right?

Should I start all over?

I removed all the lights, reset them, and then went through the pairing process again. Things seem to be working better for now.

Quick update on this. Hopefully it helps someone else. I ended up starting over with a new SD card. It seems like the old one was just not keeping up (even though it was brand new). That plus upgrading to the latest version of HA seems to have fixed things. The latest version includes default config, which means taking out a lot of things from my original configuration.yaml, but so far so good. Zigbee devices come back up on their own when restarting. And restarts now take a minute or two instead of five.

TLDR - seems like a bad SD card was causing the issues.