Zigbee going slow since updates - NUC5i7RYH

The last few days I’ve had a strange issue which has proven difficult to troubleshoot, however I think I finally found the answer. I wanted to share in case anyone else gets a similar issue. Basically majority of Zigbee devices became slow to respond, and some gave some really odd behaviour. My best guess is a change to HAOS may be the trigger. On the release notes there were some mention about additional wifi device support, this sparked me after a few days of head scratching to disable wifi in the BIOS which for now appears to have solved the issue.

Full details:
I’ve been running around 70 Zigbee devices with no issues for some time, everything is near instant.

My setup is native NUC running core 2021.9.4, Supervisor 2021.09.0, OS 6.2, Zigbee2MQTT 1.21.1-1, Mosquitto broker 6.0.1. ZZH CC2652R on USB extension, all on a NUC5i7RYH. I updated most of these in the last week from -.1 or -.2 versions. Things started to fail with one of these updates (but I was unable to pinpoint which)

I noticed the issue starting with a number of these buttons. According to the Z2M page they can give a hold action if the zigbee network is slow, rather than a single action. I noticed one button had this issue, and when checking all did. Adding delays in didn’t help reliably. Other buttons worked fine, however I think everything was running slowly, I just didn’t notice due to the stress of why the buttons were going crazy.

I don’t think I ever looked at the Z2M logs in debug mode, so I wasn’t sure what I was looking for, however I noticed a lot of messages every few seconds like Device ‘Front Door Light’ requested OTA. These repeated over and over. This seemed odd… I checked with an HA buddy and he did not seem to have similar messages, still the relevance escaped me.

I powered down every zigbee device in case I had a bad behaving router, powering back on and they seemed to work for a few minutes, I re-paired many, I paired closer to the NUC… Some things seemed to work occasionally, but none persisted long term. I restored snapshots and all the normal stuff.

It finally hit me, when I opened my under stairs cupboard, the light was taking around 5 seconds to trigger from a door sensor. Everything was slow, not just the buttons.

Having remembered about some wifi stuff in HAOS as well as the possible interference with Zigbee, (NUC is cabled, and Zigbee on USB extension), I disabled wifi within BIOS and now things have just started working, the buttons no longer dim things instead of turning on and off, sensors are back to near instant, and so on. There are no longer loads of messages on devices requesting OTA.

My best guess is somehow the on-board wifi (which I guess never worked), started working with new drivers or similar, and that it was scanning through the various frequencies, some which were perhaps interfering with the zigbee network. Perhaps this is why it worked sometimes and not others.

I am not 100% on this, and also I don’t know really how to report it as a possible bug, but here’s hoping this long post might help someone who has a similar setup. I know there is advice to not use wifi, however I was not using wifi - well at least to the best of my knowledge!

Fingers crossed


I think I love you!!!:joy:

You had this issue too @acme ?

Update: since turning off onboard wifi, everything has been back to happiness and joy

Exactly. And when I turned off wlan, everything is back to normal!
I would never think that…

This is great to hear. Thank you for the feedback.

I wrote it in the hope it would help someone else. So much pain to find the (simple) answer!

Similar hardware and software implementation, difference is using Deconz not Zigbee2MQTT.

I too had noticed that the network was a bit ‘glitchy’ with buttons sometimes needing two presses to trigger or one bulb in a group not changing when the others did. Nothing fatal but enough to be noticeable and starting to become annoying and on my snag list.

Have now disabled Wifi and Bluetooth in the BIOS and been running for 24hrs with zero issues. It could well be a placebo effect and nothing more that a couple of good reboots that did it but thank you very much for posting your thoughts/findings.

I’ll put an update on here if things take a turn for the worse but so far, so good. Thanks Again!

Hi. I have the same problem but using home assistant blue which doesn’t have Wi-Fi as far as I’m aware. Anything else that could be affecting this? It worked perfectly before the 2021.10 update.