ZigBee light hell

I’m at my witts end and about to rip out all of my ZigBee lights. Since the December update my zha lights have been incredibly unstable. Often they become completely unresponsive in the UI. A restart of HA resolves the issue temporarily, but it always creeps back in after restarting over the course of a few hours. Interestingly, it only seems to affect my zha lights and not motion or door sensors.

I use scenes for a few of the lights and have tried grouping them in ZigBee groups at the suggestion of a few others, but that has made no difference. I’ve tried rebuilding the network by leaving HA powered off for more than 30 mins, I’ve tried adding ZigBee routers (though lights all across the house have this issue, not just ones far from the coordinator.

I also have just a node red automtion that suffers from the same issues. The service call is made, the light just doesn’t respond until a restart of HA.

I’ve checked the standard things such as keeping away from wifi router, using USB extension cable to move it away from the Rpi, not using a usb3 port, etc.

I don’t see anything in the logs that would indicate an issue, unless there are separate zha logs somewhere that I’m missing. At this point they’ve become way more trouble that they are worth. What am I missing?

I’m using:
HUSBZB-1 coordinator
Rpi4 with ssd
A mixture of Cree, Innr, and Osram bulbs.

is there any chance your wifi is interfering? Do you know what channels your wifi and zigbee are using?

(And my apologies if you are already aware of this… just wanted to mention it because some do not know that they overlap)


My Zigbee is on 15 and my wifi is on either side with 2.4 and 5 the best I can tell. Unfortunately I dont have the option to change wifi channel with my current TP-Link deco m5.

I also don’t suspect this is the issue because a reboot of HA resolves it every time.

From my experience running both ZHA and ZIGBEE2MQTT for a number of years with similar devices, both on RPI3 and Intel device for coordinator. I would recommend getting a 2nd coordinator device and move your devices at a pace (that your wine consumption can handle :wink: ) to ZIGBEE2MQTT on a separate dedicated device for coordinator. IMHO, there is a reason why systems like Hue, Ikea, Aquara and others (and yes I own them all and more) have a dedicated hub that can be abstracted, moved physically away and kept running independent of your Home Assistant server. Yes, I know folks will say a combined setup works for them, often true. However, when it does not work (aka your world)… separation rules. And Zigbee is a good an reliable system, again IMHO. Good hunting!

I’ve seen this recommendation quite a bit over in the HA Facebook group, but always responses saying zigbee2mqtt doesn’t resolve this specific issue that seems to have started around December release. I’ll certainly look into it more though. Thanks!

zigbee2mqtt works fine here.

From reading your post, seems like you have a number of moving parts. I’ve been there. It is so easy to end up in these rabbit holes with what seems like a small set of unconnected changes. IMHO, I think the Home Assistant folks are doing great stuff, however your have to ask yourself who is ‘all in, with 100% resources, on a open source zigbee solutions’? It’s the zigbee2mqtt folks. I want ZHA be successful as well. However, when the ‘significant other’ is making your dinner and the lights are flaking out, you have to ask yourself the ‘hard’ questions… dinner or tech? :wink: Hope you get back to a stable setup soon! On another point, Facebook for info on Home Assistant help? Really? :wink: Stick with this forum IMHO!

1 Like

I had this issue originally when I was using a cheap unbranded Zigbee usb coordinator, especially when had added more devices to the network.

I bought a slae.sh coordinator and since then, everything has been rock solid for 3 or 4 years (using z2mqtt) and I now have around 30 devices. I was surprised how different two usb sticks could be. Also - moving it away from the computer using a usb extension lead helped.