Zigbee lighting has observably sequential settings changes


I’ve just started out with Zigbee because I bought a house with 90mm downlights, making my existing B22 lights incompatible.

I decided to go with these Nue 9W RGBW downlights and a locally bought Philips Hue Bridge.

I’ve added the Philips Hue integration and I also have the Philips Hue Android app.
Both Home Assistant and the Hue app can control the lights just fine, but I noticed that there is a distinctly sequential pathway when light settings are changed. The issue is consistent between both HA and Hue.

One example would be that if I were to change the colour from white to red, the lights would quickly change one at a time until they are all red. This is fine while I’m testing with only 4 lights, but once I fit out the rest of the house, I can see this being annoying. The total time for all 4 lights to change is roughly 1 second.
The same is true for turning the lights on, and off, and changing any other settings, including applying scenes through the Hue app.
The end goal is for HA to manage everything, but I’m still in the early stages with this lighting system.

I’m new to ZigBee so I don’t really know what this is meant to look like. Is Zigbee passing commands linearly through the mesh from one light to another at such a slow data rate that I can see the command move through the lights? Or is there something wrong with my ZigBee network?
Maybe data loss could also explain this behavior, but since it’s 100% repeatable and the timing seems to be consistent, I’m not so sure.


This has sort of gone away or reduced on its own. 1 light still occasionally lags the other 3 by a small amount. I’m waiting on 8 more lights to see if quantity has an effect.

Are you using an automation I’m HA to turn the bulbs on? If you are have you used the Parallel action to have them all turning on at the same time? You didn’t really explain what you have setup in HA specifically.

I have 3 bulbs, WiFi, in a storage room with a ZigBee switch to turn them on. I used the parallel action setup in order to get them to all turn on at the same time instead of 1-by-1.

In HA I was using manual controls on the group from the dashboard.
In Hue I was using manual controls, scenes, and whatever else on the group.

OK, so I do have a Group in HA for all 3 bulbs however I don’t have my automation that is triggered off of the button setup to use it. The reason is that my button is setup with a single/double/hold trigger automation that will turn on only 1-3 bulbs depending on the type of trigger. In the case of a build of my button I have a single action setup that will either turn all the bulbs on in parallel or turn them off in parallel. I may have set that up before creating the group.

I’ll have to check but I may also be using that group in my Vacation mode automation.

Thanks Tim,

Do your lights change state sequentially or all at the same time?

The point of my post is that I don’t know what normal is for Zigbee. Either my setup has a problem, or maybe this is just normal behavior.

My lights all change at the same time, or nearly at the same time with maybe only a super short delay, when I use the parallel action setup. However, my bulbs are WiFi and turned on as a result of my ZigBee switch as the trigger. I just tried my HA light group and my bulbs all turned on at the same time.

I’m thinking that this may in fact be a Zigbee2MQTT issue. I’m not sure if each bulb has it’s own topics in the MQTT broker. HA has to drop an individual message into MQTT for each bulb and then Z2M has to pickup those messages and process them. That could present a message processing timing issue causing your bulbs to not turn on all at once. If you use an MQTT client to watch the MQTT messages you should see how the messages for the bulbs are coming in and being processed. With MQTT a single topic has messages that need to be processed sequentially. If there are multiple topics then it is more likely that the messages can be picked up and processed at the same time.

I have it on my list to get some ZigBee bulbs to eventually replace my WiFi bulbs as I want to limit the number of IoT/smart devices on my WiFi. I’ll be curious to test that out myself.

Thanks but this post is about Zigbee end devices. I’m asking if Zigbee is the reason my Zigbee lights are noticeably sequential.
I’ll double check the wording of my question later. Maybe I need to clear it up a bit. Sorry about that.

@Mortalitas yeah, it very well could be a result of it being ZigBee bulbs, though I hope there is a good solution since I want to move to ZigBee bulbs. Hopefully someone else can chime in as well.

@Mortalitas do you by chance have a ZigBee switch for controlling your ZigBee bulbs? If so I’m thinking what might help you out is to setup Binding in Z2M so that your ZigBee siwtch directly talks/controls your bulbs. Z2M also has it’s own Scene configuration & Group configuration as well that might also be something to consider using. I know that this takes things outside of Home Assistance but bring these features closer to the devices might help with things like delays. Using Binding would also allow your switches to control your bulbs even if HA or Z2M is down.