Zigbee - Losing the will to live and about to ditch the lot

Hi folks

Been using HA for roughly 8 months and switched from ConBee II to a SkyConnect - but I continue to face issues I cannot seem to overcome.

I have 16 Zigbee devices (1 SkyConnect, 4 routers dotted around the house, the rest are end devices).

The SkyConnect is plugged into a USB 2 port on a 2 meter extension. It used to be a dedicated PC - but have recently moved to a LattePanda Sigma running HA via VM; the issue existed before.

Anyway, the problem!

I occasionally have “quiet” weeks where everything just works. Now though, nearly every day, several Zigbee devices become unavailable. The “network diagram” shows several devices not connected at all, many are grey lines, the rest are red (with the exception of 1 green between the SkyConnect and a Zigbee stairs router which are very close.

I’ve changed channels - to no avail. I’ve completely disabled the Unifi AP, so no WiFi in the house at all… also to no effect. There are other routers visible, but we’re in a private road with 5 properties… so it’s not exactly congested either.

2 TZ3000/TZ0203 door sensors, the rest are Aqara sensors
IKEA Tradfri motion sensors
A Zigbee TS0501B stair lighting router
An Aqara humidistat which, despite being spitting distance and has line of sight to the SkyConnect, disconnects daily
3 Samsung SmartThings GP-WOU019BBDWG zigbee plugs/routers

Also, battery percentages seem entirely wrong. They’re either 100% or 87% - they never change.

I’m loving the HA experience and it would be immensely useful - IF I could get Zigbee to be remotely stable.

Any advice you can give would be MUCH appreciated. Thanks!

1 Like


Not sure of all the details of your Home Assistant server setup, however I would use your Conbee II (although be careful of the firmware revision in it) to setup a parallel Zigbee2MQTT zigbee network. Fully remove (important to make sure they are fully removed and reset) a couple of your devices and add them to the Zigbee2MQTT network, see how they behave over period. I have a number of years with both Zigbee2MQTT and ZHA and I just don’t think there is enough developer resources to make ZHA a viable and solid system. Adding the complexity of this whole multiprotocol SkyConnect thing seems from my reading (I have no experience there) to be adding another layer of complexity. Just have a look at the number of new devices and fixes to existing devices that are going on between the two systems, hands down it just seems there is so much more work and solution in the Zigbee2MQTT system. Zigbee is a solid automation system with a lot of years behind it and it should ‘just work’ for you. I seriously doubt you have any RF interference issues, so much wasted time has going down this route due to false info and bogus ‘monitoring’ info from systems (unfortunately) such as ZHA’s messages about channel utilization. I would bet if the problem is not just with bugs in this new complicated coordinator, that you have a routing device with bad firmware. And from my experience, it will be doubtful if your ZHA system has the ability to upgrade the firmware of many of your devices (not to make that too much a false hope, because the compatibility and compliance of some of the Aqara and Tuya zigbee devices is sketchy).

Good hunting!

I was considering zigbee but steered away from it. I’ve got 65 Yolink devices which are pretty much up 100% of the time (except every 6 months or so things act wonky and a reboot of the yoling hub fixes that), then I also have 14 shelly relays (one even in a different building that connects to the wifi in the home with no issue) and they have bveen 100% rock solidt with connectivity never going down. I halso hjave a leviton decora 2 wall switch which is slow to react sometimes and about 10 wemo devices (smart plugs mainly) which are ok about 80% of the time.

If you can, and I am tempted to do this too, consider switching to all shelly hardware. I reserve an ip address for every one of them and set them up a specific way (websockets) and once I got them set up that way they have been rock solid -

I am mostly Zwave but also a few Zigbee devices. I believe that your issue may be the mesh network, meaning that your devices may not always reach your HA hub. Battery devices do not repeat the signal, so be sure to add a few plug-in (or other non-battery) devices to expand the mesh network.

1 Like

That comment does not help the OP, and FWIW, my Zigbee mesh has been rock solid for the last 4+ years.

The skyconnect (and it’s brother, the Sonoff Zigbee Dongle Plus - E) does not seem the most stable according to the topics on this board.

1 Like

Morning Paul - sorry to hear you’re having a bad time. Looks like you’ve hit most of the high points and general recommendations.

I’m interested in a few things. What devices actually become unavailable - is it always the same devices?

How far apart are your end devices from the closest powered repeater. How far is the repeater from the coordinator?
You said you turned off your 2.4G Wi-Fi - that simplifies things and interference likely isnt causing this - but TBH i’d rather optimize it with your network in place so you don’t have to do that one again when you fix this. What channel are you on for Zigbee and 2.4G wifi when it’s back RUNNING

What is the EXACT model of the Aquara / Ikea sensors in question, incl. firmware level?

I seem to remember some kind of weird interaction between some end devices and Samsung’s ST plugs where they didn’t play really nice and started to drop messages (eventually leading to dropped end devices when they don’t heartbeat properly) But I can’t find the link on ST’s community site right now. But in any case, - unless you are trying to span extremely long distances and are just running into signal strength issues - I’d look for anomalies based on interactions between the model / firmware level of your end devices that are dropping and your router. Unfortunately, because of some manufacturer’s specific clusters and anomalies some certain devices dont always play nice with others and it may just be as simple as switching out a few pocket sockets.

Also on the batteries. IOT battery gauges are horrendous. I only use mine to compare a device against it’s own past performance… That’s pretty typical.

1 Like

Fair enough

Firstly, wow. Thanks for so many replies so quickly!

dproffer - I am trying that as we speak. You mentioned being careful with firmware on the ConBee II - is there a specific version (apart from latest) I should be using/avoiding? I’ll come back to you shortly after some testing!

KruseLuds - I run several Shelly’s for lights too - they are absolutely rock solid. I didn’t know they offered door/motion sensors too. If Z2M proves unreliable too, I’ll explore that. Thank you!

EndUser - I already have several routers dotted about - in the form of plug sockets and a Zigbee LED lighting strip. I’m not sure it’s viable placing any more… as they’d be cm apart, rather than metres.

NathanCu - It’s almost always the TZxxxxx door sensors or the Aqara humidistat which go offline/unavailable. No idea why - but I replaced several Sonoff motion sensors for the same reason, thinking it was those.

On average, there’s about a 3m gap between each device and the nearest router. I’ve spaced them out (I think) quite efficiently so they’re equidistant for the most stable connection. There’s bound to be some outliers, but for the most part, 3/4m tops.

I’ll check the firmware for everything - just in case.

Thanks again everyone. Will update you soon.

Have you followed @Hedda’s troubleshooting post? Particularly zigbee channel selection part?

Is the Aqara connecting directly to the coordinator or via a router? Try re-pairing via a router, maybe even try an alternate router. Older Aqara devices are very sticky to the device they originally pair with, even if it is not the best option.

I only have a couple of Tuya devices. They seem to re-home themselves pretty readily, but re-pairing via an appropriate router wouldn’t hurt.

I know you’re near the end of your rope, but I’d get a ZBDongle-P or other cc2652 based stick if you want to try z2m. Conbee support is good by all reports, but the z2m dev uses a cc2652 stick (and maintains the community firmware for cc2652 sticks).

Anecdotally, I find the ZBDongle-P the better performer vs SkyConnect under ZHA for me, but it might just be my device/environment mix.

I have 26* based zigbee stick and 80+ zigbee devices spread around house with concrete walls. For time to time some zigbee devices need re pairing. Mostly that’s battery powered motion sensor. Light switch very rare, outlets and smart plugs almost never.
I had to repair some of devices after blackout.
As I monitor my zigbee devices avability using uptime kuma I noticed that some switches, mostly always the same, go offline and than back online by it self.
I traced out this problem and found out that this is due bluetooth connection used by my brother computer.
When his computer is not in the house everything is working fine. No droped connections, nothing.
Bluetoith is definitely zigbee killer. Except the devices it self you might be facing some interference that is killing your zigbee network.

I will be interested in hearing the results of your experimenting with Z2M. As to the Conbee firmware version, I do not have direct experience with this device, I just was checking at the Z2M web site to see if what I was proposing to you was possible with the Conbee dongle. That is where I saw the warning about the newer firmware causing issues. Which to my experience with other coordinator dongles and firmware versions, I have found very little value in chasing any firmware upgrades of my coordinator devices. My lesson, find a version that is solid and don’t screw with it.

To your config. I run my stuff on an x86 box and run many things in Docker (I’ve blabbed 'bout this in other posts so will not bore boar you. However, I have two zigbee dongles, one production one test, and two docker containers, again production and test. It is so easy to upgrade and (if necessary) downgrade and test new devices with this docker setup.

I also used to have the same kind of problem with SkyConnect and ZHA. There came a time when I had to turn the coordinator off and on again every 2 days because the devices stopped working.

My system runs on a Raspberry Pi4 4GB with HA OS and almost 40 zigbee devices. I used a 2m USB cable between the Raspberry and the coordinator, and mitigated all 2.4GHz WiFi interference, including asking the Internet provider to turn off the fiber gateway’s free WiFi network. Nothing seemed to solve the instability problems.

Finally, I packed the SkyConnect back into the box and bought a Sonoff ZBDongle-E.

With the coordinator in the same location, with the same USB cable, the same Raspberry Pi, the same 40 devices, and it just works. I don’t even remember about it anymore.


My Zigbee network has many red and weak signal connections but it is working. The house has 4 floors and the devices (light switches, shutter controls and motion / temperature sensors) are installed all over the 4 floors. I also had 3 IKEA repeaters but I removed 1 because didn’t find any gain.

I’d like SkyConnect to work the same way, because it has the advantage of Matter support, but unfortunately I don’t think I’m going to risk another radio migration if/when a new firmware appears.

After literally hours of hassle with the ConBee II/Z2M (it wouldn’t start), I’ve reset HA and used the SkyConnect with Z2M.

Everything is added - all automations updated. Now we wait.



  • A few things.

I am assuming that you are using ZHA since you are using the skyconnect silabs dongle, which I have purchased but only installed it for learning, Ive always used zigbee2mqtt as it has been rock solid for me. Ive run zigbee2mqtt as both a standalone docker and as an HA addon.

If ALL your devices are going offline as opposed to SOME, then you most likely have an issue with the coordinator (which is your skyconnect dongle). So it will make no difference how you position your end points and routers if this is indeed the fault.

There is anecdotal evidence that the skyconnect with the dual openthread firmware is unreliable. I am actually running it as a second network, albeit with no devices attached it yet. I am keen to learn about matter and openthread, but as I have nothing attached I can neither confirm nor deny the anecdotal evidence.

My suggestion, if you are willing would be to invest in a relatively inexpensive but incredibly reliable cc2562r* TI based stick and flash it with koenck’s zStack3x0 firmware (use the ZigStarGW-MT GUI for very easy flashing on Windows or Mac) and run zigbee2mqtt instead of zha.

Yes zigbee2mqtt coordinators can chuck a wobbly (there, now you know I am Australian), but this is usually simply resolved by reflashing the stick - I have done this maybe 3 times in 3 years. Usually due to multiple power failures on the server.

I promise you will be happy.

This is me

I had the exact experience as filipesa, except I went back to my ConbeeII.

Same issue here.
Came from Openhab with a dedicated Phoscon/Conbee Container. Didnt play nicely in Homeassistant, so I moved on to Z2M with a new Sonoff E stick. No joy either. Tested the slightly oder Sonoff D stick. No joy. Moved to ZHA with both sticks. No joy.
Also found the referenced tutorials and changed dongle position, USB cables, Wifi channels, etc.
I have about 20 devices. 15 mains powered acting as repeaters. mainly Hue lamps. And a few IKEA remotes. It all starts nicely but soon devices get partially unresponsive. Even the mains powered ones that are literally 3 meters away from the USB dongle (same floor level).
Currently deploying the Addon Phoscon container to test the good old ConbeeII once more.

Pretty sure Hue devices will only work as proper repeaters for other ZigBee LL devices. Might be attributing to your issue.

I’ve had the Sonoff E stick setup since day 1 with Z2M and haven’t had any issues with 51 devices. I do have dedicated Ikea repeaters along with a few ZigBee 3.0 mains powered devices that repeat.

My setup includes more than 40 zigbee devices using Conbee II and zigbee2mqtt. More than half of devices are from Aqara.

Everything works fine. Aqara devices are known to be sticky to the router they are paired with. So if you move them to other places they can lose their connectivity. But I haven’t experienced that.

Bummer that you had the issues with the Conbee adapter. Because from reading several of the posts here, by keeping the SkyConnect in your equation, you may not have eliminated a possible likely problem point. I do think you will find a better experience and debugging/maintenance tools in the Zigbee2MQTT universe, so hopeful that you are making progress.

I would set Z2M logging to the debug level for a while and monitor what you see in the log. What does your Z2M ‘map’ look like after an hour or so after a start of the coordinator? That will give you a feel for where and how things are connecting back to your coordinator.

Yes do follow all these tips regardless → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage