Zigbee mesh stops working with switch to M.2 SATA

Hey all

I have recently bought an Argon One M2 case and installed a SSD in it. I have a wierd issue with Deconz/ConBee II I can’t get my head around.

I’ve copied my existing SD card to the SSD using dd, as far as I’m aware it’s an exact copy. However when I boot the pi off the SSD, everything works except the Zigbee devices. Looking at the Deconz mesh, I see no green lines. If I switch back to the SD card, everything comes up within a few minutes.

Any ideas?

1 Like

Add a USB extension cable to move the Conbee2 Zigbee radio away from the USB ports. The USB SSD creates a lot of RF noise. This is a very common issue when running a RPi off of a USB drive.


Just wanted to come back for anyone who reads this. Ogiewon’s solution worked, after adding an extension the mesh came up immediately.

1 Like

Same worked for me.


Sometimes the simplest solutions are the best!

Lesson learned, be sure to always follow best practices → https://github.com/zigpy/zigpy/wiki/Generic-best-practice-tips-on-improving-Zigbee-network-range-and-general-stability

I mean yeah. It’s good advice. But why would I be looking at the ZigPy best practise document when I am running a Conbee stick with Deconz

Read it, the advice there is generic for all Zigbee and nothing mentioned there is specific to zigpy/ZHA.