Zigbee MQTT Tradfri Light

I set up my Tradfri bulb in Zigbee2mqtt. I manually configured it in the lights.yaml file as follows:

- platform: mqtt
  unique_id: bedroom_ceiling
  name: "Bedroom Ceiling"
  state_topic: "zigbee2mqtt/Tradfri/state"
  command_topic: "zigbee2mqtt/Tradfri/set/state"
  payload_on: "ON"
  payload_off: "OFF"
#  brightness: true
#  color_temp: true
#  xy: false
#  hs: false
  brightness_command_topic: "zigbee2mqtt/Tradfri/set/brightness"
  brightness_scale: 255
  brightness_state_topic: "zigbee2mqtt/Tradfri/brightness"
  color_temp_command_topic: "zigbee2mqtt/Tradfri/color-xzigbee2mqtt/Tradfri/color-x"
#  effect: true
    - "blink"
    - "breathe"
    - "okay"
    - "channel_change"
    - "finish_effect"
    - "stop_effect"

How can I get the brightness and colour temperature settings into a slider and a drop-down menu on the Lovelace interface? I tried adding a separate entry in input_slider.yaml but I can’t figure out how to link it to the brightness part of the light. I suspect I’m going about this the wrong way. It seems to convoluted to set up a simple thing so any advice would be greatly appreciated.

p.s. If I click on the light it comes up with a little card with the slider which works but I want to be able to do it directly from the interface. Also, there doesn’t seem to be a way to change the colour temperature either. I copied the above from the Zigbee2mqtt website.