Zigbee network utilization - options

Hi Folks,
Running HomeAssistant (HAOS Core 2024.2.3) on a Raspberry Pi 3 with Sky Connect ZHA adapter. Started running into issues with HA not being able to send messages to some of the bulbs. Poking through the logs and find the following error message below. I have 56 devices on this controller and a wifi network with both 2.4G (for older IoT devices) and 5G networks.

The ZHA adapter is on a dongle to keep it away from the Pi and there are several access points throughout the house but not next to the Pi.

From reading I’ve learned that ZHA Chan 11 is not the same as Wifi Chan 11 so I’m reaching out to ask:

  1. Do I have too many devices on this controller?
  2. Is there a tried and true method to figure out if the Wifi is interferring with Zigbee or am I at the mercy of just trying different channels until something works reliably?
  3. Is there something else I should be doing?

Logger: zigpy.application
Source: components/zha/core/gateway.py:214
First occurred: February 23, 2024 at 4:43:49 PM (2 occurrences)
Last logged: February 23, 2024 at 4:43:49 PM

Zigbee channel 11 utilization is 99.57%!
If you are having problems joining new devices, are missing sensor updates, or have issues keeping devices joined, ensure your coordinator is away from interference sources such as USB 3.0 devices, SSDs, WiFi routers, etc.

It depends… What kind of devices are they? Some people run hundreds, but a large number of them will be mains-powered routers. You mention some bulbs, so they’re probably routers. Battery powered sensors are parasites - they consume network resources and contribute nothing.

If you’re using ZHA you can check channel usage by going to the ZHA card in Devices & Services, clicking on the three dots next to Configure and selecting Download diagnostics. Right at the end of the file you get will be something like this:

    "energy_scan": {
      "11": 73.50699819621309,
      "12": 3.2311094587038967,
      "13": 70.89933442360993,
      "14": 91.05606689948522,
      "15": 85.82097888710312,
      "16": 65.26028270288712,
      "17": 7.659755505061292,
      "18": 43.057636198227904,
      "19": 1.1664179210724432,
      "20": 62.257682586134884,
      "21": 2.509919386096536,
      "22": 3.6632469452765037,
      "23": 4.15070068297423,
      "24": 0.9017765778954641,
      "25": 1.5075412082833717,
      "26": 21.09014924761344

The percentages show the amount of noise on each channel, including Zigbee traffic, wi-fi traffic (your neighbour’s as well as yours) and general interference.

Lots of advice in the Community guides:

1 Like

Same question and answers as this other thread here → Zigbee Utilization 90%, normal for 130 devices?

You can have 200 Zigbee 3.0 or there about (and even if more older Zigbee devices as their lower security have less overhead) but that depends on you having enough Zigbee Router devices and avoid EMF interference, see → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

1 Like

Hi @Stiltjack ,
First, thank you so much! I’m trying to come up to speed on these topics so there’s lots of reading to do. Appreciate the pointers in the right direction!
All except for 3 devices are light bulbs (Philips Hue, Sengled) and three motion detectors to turn on bathroom lights. Those sensors are indeed battery powered.

Looking at the diagnostics, it’s seems the optimum channels would be 24, 21, 25 in that order if I’m reading this correctly. I changed the channel to 21 (as I read that some devices can’t utilize 24) but in doing so noticed that the SkyConnect has a setting for auto in the channel configuration. I’m hoping that’s like Wifi in which it was attempt to switch channels if there’s too much congestion.

"energy_scan": {
  "11": 99.50848219356503,
  "12": 99.7071990109242,
  "13": 99.77408388719513,
  "14": 99.27573563839312,
  "15": 80.38447947821754,
  "16": 78.25348754651363,
  "17": 82.35373987514762,
  "18": 80.38447947821754,
  "19": 75.96022321405563,
  "20": 25.74050169409602,
  "21": 15.32285793082191,
  "22": 21.09014924761344,
  "23": 31.01324838787301,
  "24": 8.631361812931262,
  "25": 17.086630587133605,
  "26": 82.35373987514762

It is not, Zigbee will never switch channel automatically. That ”auto” option only means it will automatically do a scan then select the channel with least amount of radio noise when initially forming the Zigbee network

I don’t think Sengled bulbs are routers.

Thanks @Stiltjack Appreciate the pointer to the DB and the heads up on the auto channel. It looks like I’m going to have to start all over. I switched channels, none of the devices migrated :frowning: then restored from backup and everthing is still broke.
Disappointing for sure…

More tips in this other thread: