Zigbee sensor not linked to closest router

I am gradually migrating my ZigBee sensors from Smartthings.
I made the error of migrating some of the sensors before migrating all the devices acting as routers.
What I see now is that the routers are correctly linked each other, but some of the sensors are connected to routers that are really far, instead of connecting to the most recently installed routers that are much closer.
Do someone know if there is a way to optimise the connections of the sensors without uninstall and re-install each single sensor?

Thank you

If you talk about Xiaomi sensors, you will need to re-pair them in their final position. For other sensors : the will find the best route eventually.

Hi, i was thinking in that way about Xiaomi (or aqara) ones but apparently after restarting my pi, they sometimes might jump to another repeater. While everything is working fine, they always stick with the one which they were paired. In panic situation, they were able to move to another one.

The sensors with which I am having problems are: SmartThings sensors, Aqara and Ikea.
I tried with a restart of HA but this did not work.
How does it work with Panic Mode? Should I just switch off HA for 30 minutes or do I need to switch off all the routers?
Is there a way to re-add a sensor without losing all the configurations and settings in the automation?

I had moved my pi from 2nd floor to garage and some aqara sensors were connected through main coordinator and then because of misisng coordinator, they had jumped into a light bulb. That was really strange, as i was expecting to setup from stratch.

So, maybe you can try to remove connected coordinator from the network while network is offline and start the network later on.

Thank you, I am going to do a test

I have a similar question to the OP.
I have two Aqara temp sensors which I want to connect to different routers. I have tried taking them into the rooms with the strong nearby routers and re-pairing them WITHOUT removing them first. ZHA finds them again with no problem, but on the visualisation it looks like they are still paired with the original routers.

I am hoping that the visualisation might change over time - maybe I looked too quickly.

I know the advice has been this:

And this same advice from another topic:

I want to check: when people are re-pairing these Aqara sensors, are you removing them first? I don’t want to lose my historical sensor data, if I can help it!

No. And even if you did it would not remove the database entries until the purge time at 4am 10 days later (assuming you add them back with the same entity id).

OK, that’s a relief on several fronts. Re-pairing without removing devices hasn’t resulted in router changes for me, so I will try removing (noting entity names carefully :slight_smile: ) and re-pairing as new.

Thanks @tom_l :grinning:

Did that work?

1 Like