Zigbee sensors become unavailable after restart

Hello all, newbie here. I have created a small ZHA network with some sensors. The problem is that after a restart all sensors become unavailable and stay that way.

My installation details:

  • Home assistant OS (2024.4.1) running on a x86 mini-pc (dedicated)
  • Sonoff Zigbee USB Dongle Plus
  • Temperature/humidity sensor
  • Flood detection sensor
  • Open/close sensor
  • Presence sensor

All sensors are from Aliexpress (the zigbee/tuya most popular ones). They are all close by to the usb stick, one of them is 50cm away, so it’s not a range issue. They all show 100% battery in the interface (after I set them up).

What I tried so far:

  • Read other posts about this topic - seems to be unresolved (?)
  • Wait - after some hours only the presence sensor became unavailable due to me moving around
  • Reboot homeassistant PC - the sensors are still unavailable
  • Take out / reinsert dongle in PC - no change
  • Press reset button on each of the sensors - they connect and continue working as expected.

Could I try something else? Thanks a lot for the help.

Do you use an USB extension cable on your dongle ?

What is the version of the firmware ?

1 Like

Thanks for the quick reply, Francis. I use the dongle connected directly to the minipc. Does it matter in which USB port I plug it in? I currently use one of the front ports which should be USB 3.

The firmware version that I see from within HA looks like this:
Device info
by Texas Instruments

Firmware: Z-Stack 20210708


Yes it very much does so, (and you should not use USB 3.0), see → Zigbee networks: how to guide for avoiding interference + optimizing using Zigbee Router devices (repeaters/extenders) to get best possible range and coverage

I have plugged the zigbee adapter into one of the USB 2 ports at the back. When I restart the pc the sensors no longer show as ‘unavailable’ however their status doesn’t change (temperature is reported the same as the one just before restarting), until I push the reset button on the sensor, then it works as usual.

Is there anything else I could try?

The extension cable.

Try 20230507. . And use an USB extension cable

Small update - it seems that after a longer period of time the sensors are sending back data. I will test today to see how long it actually takes and if they are stable.

One thing that I’ve found working in same kind of situation, is to shut down the server, wait a minute, and then start the server. Just restarting the server makes the Zigbee sensors, and the Zigbee2MQTT unresponsive.

I tested again the system, by shutting down for 30 minutes then booting back up. I get data from the sensors after 3 or 4 hours (!). Is this normal behavior?

I also tested a USB 2 extension cable and placing the dongle where there aren’t any other electronic devices. Same result.

I guess next step is to try updating the firmware?