Zigbee Setup

I’, trying to use a Sylvania light switch with HA. The auto-discovery recognizes it as a CentralLite sensor and thinks it’s detecting temperature. I’ve tried to over ride this:

usb_path: /dev/ttyUSB1
database_path: /config/zha.db

First this way:

  • platform: zigbee
    name: Lightify
    type: analog

Then this way:

  • platform: zigbee
    name: Lightify
    entity: sensor.centralite_3130_00f8e58e_1
    type: analog

And I keep getting this:

2018-01-20 23:17:48 ERROR (MainThread) [homeassistant.setup] Error during setup of component zigbee
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/homeassistant/setup.py”, line 199, in _async_setup_component
component.setup, hass, processed_config)
File “/usr/lib/python3.6/asyncio/futures.py”, line 332, in iter
yield self # This tells Task to wait for completion.
File “/usr/lib/python3.6/asyncio/tasks.py”, line 250, in _wakeup
File “/usr/lib/python3.6/asyncio/futures.py”, line 245, in result
raise self._exception
File “/usr/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/lib/python3.6/site-packages/homeassistant/components/zigbee.py”, line 90, in setup
usb_device = config[DOMAIN].get(CONF_DEVICE, DEFAULT_DEVICE)

I’ve tried editing the DB file. No luck. There has to be some way to make this work, no?

Anyone got an idea for this problem?

I don’t have an idea as of yet, but am running into the same issue trying to setup a zigbee motion/temperature sensor. Have you since been able to resolve this?