Zigbee Sonoff USB can't create network

Hi, recently I buy a Sonoff Zigbee 3.0 Dongle USB but wen i tried to create the network get an Error and show this on logs:

Source: components/zha/radio_manager.py:224
First occurred: 20:28:25 (1 occurrences)
Last logged: 20:28:25

Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.11/site-packages/zigpy_znp/api.py", line 228, in load_network_info
    await self._load_network_info(load_devices=load_devices)
  File "/usr/local/lib/python3.11/site-packages/zigpy_znp/api.py", line 134, in _load_network_info
    nwk_frame_counter = await security.read_nwk_frame_counter(
  File "/usr/local/lib/python3.11/site-packages/zigpy_znp/znp/security.py", line 109, in read_nwk_frame_counter
    raise KeyError("No security material entry was found for this network")
KeyError: 'No security material entry was found for this network'


I am having pretty much the exact same error, but with slightly different line numbers. Did you ever resolve this?

I had an easily working ZHA integration earlier, but tried moving to zigbee2mqtt, which was very unstable for me. Eventually, my whole system crashed, and couldn’t restart, so have re-written the SD card with HA OS, and am running on a fresh system. It sees my Sonoff Zigbee 3.0 Dongle USB plus, but whenever I try to create a new network, I simply get “error.” The HA logs show what you’ve shown here.


OK, I’ve solved my problem. I tried all of the “move the dongle away from the rpi 3b+” suggestions, tried rebooting, etc. No joy. So, I bit the bullet, downloaded the Zigstar Multi Tool cross-platform firmware flasher (ZigStar Multi Tool cross-platform firmware flasher and backup/restore GUI application for any Zigbee adapter based on CC2652, CC1352, and CC2538), downloaded the latest Z-stack firmware for my dongle, and re-flashed it. I also DID use a USB extender. Flashed successfully, easily.

And, when I restarted the pi with the new stick attached, it recognized it, and successfully configured ZHA. I’ve now re-established my zigbee network (small as it is), Hopefully this’ll help someone else struggling with the same problem.