Zigbee switches respond slow

I am using Home Assistant OS on a Raspberry Pi 4 with conbee II (using a USB cable on a USB-2 port). I have 20 Zigbee devices in total (light bulbs, sensors, switches). All seems to work just fine. However, I have two switches which I use to control the light bulbs. Whereas controlling the lights from lovelace works really fast, I have significant delays (at least 5 seconds) when controlling from the switches.

As an example, one switch is the Aqara WXKG11LM Rev.2 and I use the following, simple automation (actually created using the UI, not in YAML):

alias: Wohzimmer Lichtschalter
description: ""
  - device_id: f46c962e9073029cb5e2b475cea49652
    domain: deconz
    platform: device
    type: remote_button_short_press
    subtype: turn_on
condition: []
  - type: toggle
    device_id: f9655d862a8281a5b138afa8bae793fe
    entity_id: light.wohnzimmer
    domain: light
mode: single
max_exceeded: silent

The other Switch is a Phillips switch with a more complex automation.

What could be the reason for the delay, since the lack of delay using lovelace excludes a lot of possible reasons like interfering Wifi frequencies, interference from hardware, range, and so on?

If the lovelace UI change in the lights is very fast, it would suggest the remote switch might have poor signal or latency. Have you tried using the same switch to control some other device (like turning on/off a smart plug) and seeing if the delay also happens with that ?

That would at least pin it down to the switch.

Thank you. While doing that and seeing that the delay was not as pronounced, I realised that the lights I’m controlling with the two switches are the only ones that are grouped, my other rooms only have one bulb each. Is it better to add each single bulb to the switch automation instead of using a Deconz group? I guess somewhere there is the source of the delay

I changed everything in the automations to single entities instead of groups. I’ll have to test this tomorrow.

What I noticed before was that once the lights responded, toggling them using the switches was quite fast. Felt like some sort of power save mode. I reckon there is no such thing in Zigbee?

I also have Philips and aqara switches in conbee 2. I don’t have any delay.
Try to check logs of deconz and ha. Go to deconz to see networks and debug logs and do some tests

I don’t think it should matter if you use groups, individual entities or scenes to control the lights as far as latency goes.

The problem is resolved. Sadly, I cannot give much information about the solution. Since then I switched from an A1 to an A2 SD card, which made my whole instance a lot faster (especially boot up and webui) but I am not sure whether that could have solved the latency problem as well.