Zigbee TRV keeps "resetting"

I have a Wiser TRV paired in ZHA.

I set the thermostat in Home assistant to HEAT, but after some time, which varies, it “resets” to Heat/Cool.

This happens consistantly, and will not stay on HEAT permanently.

Has anybody had any experience of this?

Lawrencez - I am new to this… and only plugged my first zigbee TRV in yesterday ! I have a Wiser TRV, connected to ZHA on a Raspberry pi 4 - through a Sonoff Zigbee 3 USB dongle. I have exactly the same issue. Connected the TRV up fine through the integration. Current temp and set temp all show up. But when I change TRV setting to Heat (instead Heat/Cool) and to a different set temp - the TRV seems to revert to the original setting after some period of time.
If any one has any ideas on this - would be very interested !!! (or do I need to change to a different TRV ?)

Same issue here with Drayton TRVs.
I used zigbee2mqtt for months and recently tried ZHA but no improvement.
Also tried different coordinators like slaesh, sonoff and conbee2.
I am not certain but I believe that this behaviour started at some point this year…
I am considering the idea to buy the thermostat/hub from Drayton as that would solve the issue?
I am assuming the system could then be integrated and managed via home assistant

also have same issue Drayton TRVs. does anybody find solution ?