Zigbee 'usb_path' option deprecated?

Noticed in “Developer Tools” under “Logs” there was this message:

2020-05-23 18:09:12 WARNING (MainThread) [homeassistant.components.zha] The 'usb_path' option (with value '/dev/ttyUSB1') is deprecated, please remove it from your configuration. This option will become invalid in version 0.112

So, I can remove ‘usb_path’ from the zha section of my configuration.yaml???
I’m using a HUSBZB-1 for my Zwave/Zigbee controller.

Here is what is in my configuration.yaml file:

# Configure a default setup of Home Assistant (frontend, api, etc)

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

# Zwave config
  usb_path: /dev/ttyUSB0

# Zigbee config
  usb_path: /dev/ttyUSB1
  database_path: /config/zigbee.db


# Time & Date Sensor
# Example configuration.yaml entry
  - platform: time_date
      - 'time'
      - 'date'
      - 'date_time'
      - 'date_time_utc'
      - 'date_time_iso'
      - 'time_date'
      - 'time_utc'
      - 'beat'


Yes, if you see that it was already imported to .storage/core.config_entries so you can remove it from configuration.yaml.

1 Like

I just saw this today. Exact same config entries for my HUSBZB-1 as the OP.

To be clear, should I just delete the usb_path: line and leave the database_path: line,
OR delete the entire zha: entry?

Nobody mentioned the zwave: / usb_path: entry for the same stick, so I assume we leave that one alone (at least for now.) Am I correct?

Thank you!!

You can remove usb_path: and leave database_path: for now.

1 Like

Please ignore the message, since it’s not specific to zha. I created a new forum thread covering both zha and zwave.

I am getting the general warning message below (not specific to only zha); suggesting for me to remove any lines me that contain “usb_path

</s> <s>[homeassistant.components.zha] The 'usb_path' option is depreciated, please remote it from your configuration. This option will become invalid in version 0.112</s> <s>

If I were to remove both lines containing “usb_path” below, should I expect both z-wave and zha controllers and respective connected devices to still work correctly? How would someone add these devices to a new HA setup if these lines shouldn’t be used?

usb_path: /dev/ttyS1
device_config: !include zwave_device_config.yaml
network_key: “0xa1, 0x1d, 0xb7, 0xa7, 0x11, 0x7a, 0x4c, 0x2f, 0x20, 0xfa, 0x10, 0xea, 0xdc, 0x18, 0xcc, 0xce”

usb_path: /dev/ttyS0
database_path: /config/zigbee.db

I recently removed my zwave USB-path, and all works fine. Again, verify it is in your core/config_entries first before changing it. FYI, on a fresh install those integrations will ask for the paths (and network key for secure zwave) when you run the startup flows (right after adding the integrations).

This may sound crazy, but how do you check the core/config_entries for the path. My Zwave is working fine with my fresh install on a RP 3+, but I cannot get my ZHA to pair anything. Using a Nortek stick.

Thanks in advance.

config/.storage/core_config.entries, should look like this:

    "data": {
        "entries": [
                "connection_class": "local_push",
                "data": {
                    "device": {
                        "path": "/dev/serial/by-id/usb-Silicon_Labs_HubZ_Smart_Home_Controller_612011D2-if01-port0"
                    "radio_type": "ezsp"
                "domain": "zha",
                "entry_id": "XYZ",
                "options": {},
                "source": "user",
                "system_options": {
                    "disable_new_entities": false
                "title": "Zigbee",
                "unique_id": null,
                "version": 2

Note the by-id path is found using this in terminal: ls -l /dev/serial/by-id/. The by-id path is the preferred method of defining a usb path in HA (and not just for the ZHA integration).