Zigbee2MQTT add-on upgrade instructions requested

Since 2 days there is an updated Zigbee2MQTT, version 1.18.1-1.

I’m still running 1.17.1-1.

The auto-update option is enabled in my add-on and I also restarted the add-on but nothing changes. I suspected to see a button to upgrade to the new version.

Anyone experience with this?
How can I manually upgrade without loosing all my devices and setup?

1 Like

me too, I’m still running 1.17.1-4

Indeed, there is no update information. You have to do it manually.
I just figured out how:

1/ Take a backup of your configuration
2/ Uninstall Zigbee2MQTT
3/ Re-install it (click on the 3 dots in Supervisor -> Add-ons -> Respositories and enter https://github.com/zigbee2mqtt/hassio-zigbee2mqtt)
4/ Then re-install
5/ ‘Re-load’ your existing configuration

The above steps worked for me, hopefully also for you.
All existing, joined devices, will still work after the upgrade.


Hi, can you give more details about step 1 and 5?
For step 1, what file have we to backup? I’ve the zigbee2mqtt configuration at path /usr/share/hassio/homeassistant/zigbee2mqtt, backup this folder and after installation of new version rename it with original name?
For step 5, how to reload the configuration?

1 / Go to Supervisor. Select ‘Zigbee2MQTT’ from the installed Add-ons.
Once there, on top you have 4 tabs. Click on configuration.
Select all and copy/paste it to a local file, for example .txt file

5/ Once the new version is installed the configuration has the default values.
So open your local file and do the opposite:
Go to Supervisor. Select ‘Zigbee2MQTT’ from the installed Add-ons.
Once there, on top you have 4 tabs. Click on configuration. Paste the data from your file here.

Thanks a lot, for your information, with latest version i’ve added repository and executed update on old version only so now is very easy to update.

1 Like

This worked for me as well. Thanks

1 Like

Hi, can you provide details on what you did ? Thanks

The Home Assistant UI has changed slightly since the original solution was posted.
I just had to go through reinstalling Zigbee2Mqtt 1.28.0-1 on HA 2022.10.4.
The steps are basically the same:

  1. Go to Settings>Add-Ons. Select Zigbee2mqtt.
  2. Select the Configuration Tab, then click on the three vertical dots in the upper right. (See Photo)
  3. Switch to Edit in YAML. Highlight all the YAML code on the page and paste it into a .txt file (I used Notepad in Windows). Save the file.
  4. Click the Back arrow in the upper left and/or return to the Zigbee2Mqtt Add-On dashboard. Select UNINSTALL.
  5. For safe measure, restart Home Assistant.
  6. In a browser, navigate to: GitHub - zigbee2mqtt/hassio-zigbee2mqtt: Official Zigbee2MQTT Home Assistant add-on then copy the URL.
  7. Once HA has restarted, navigate to Settings>Add-Ons> then Click on Add-On Store. Click on the three dots in the upper right and select “Repositories”. Now paste the URL you saved in Step 6 in the dialog box and click Add. Then click the Close button. Now – important – REFRESH YOUR BROWSER.
  8. You should now see the new version of Zigbee2Mqtt listed in the HA Add-Ons. Click on it to install.
  9. Now you’re going to paste the YAML code you saved in Step 3 into the YAML of the new installation. So, Open Zigbee2Mqtt, (Do not click on Start yet!) Click the Configuration tab> Click on the three dots> Select Edit in YAML. Remove the YAML that’s there and replace it with your old YAML code (from the file you saved). Click SAVE.
  10. Restart Home Assistant.
  11. Return to the Add-On (Settings>Add-Ons>Zigbee2Mqtt) and select Start. You may also want to turn on Watchdog and Show in Sidebar. Give it a minute or so and you should find all your Zigbee devices.

Thanks, @Lonestar10!
That worked nicely!

Thanks @Lonestar10 !!! This solution works perfectly for me!

Do I really need to backup, uninstall, reinstall and restore the backup? Can’t I just use the HA update feature for the addon in the settings?