Zigbee2MQTT aqara roller cover entity not exposed over mqtt

I can control my aqara e1 driver from inside home assistant however there is no cover entity showing up outside of zigbee2mqtt:

Exactly the same thing has happened to me, and not only with the aqara device but also with several plugs of Tuya in all of them the option to turn off or turn on has disappeared, in mqt it appears.

Solved: Rollback to docker image to zigbee2mqtt:1.32.2

I ended up switching to ZHA instead

Also found this: PSA: MQTT Name changes in 2023.8

The problem in OP’s post is happening with me too on latest z2m, so rolled back to 1.30 or so as well which has fixed the issue for now…

Zigbee2MQTT is working fine for me on the latest version (switched back after new hass release)