zigbee2MQTT auto deleting device settings

Since rebuilding zigbee2MQTT about 2 weeks ago while moving to the smlight coordinator I have been unable to change any device settings.

I would like to enable retain and Qos.

If I check the Retain option, it auto unchecks it within a second, certainly before I can press the save button.

It is the same for every device setting field on every device.

I have tried using the Home Assistant iPad client, I have tried safari, chrome, on iPad and on MacOS.

It is consistent.

I have rebooted iPad and Mac.

As far as I am aware this is a vanilla install.

Anyone any ideas on how to fix this?

Change the log level and try to do the settings again and see what pops up in the logs.

1 Like

Nothing debug logs,

However if I can select Retain and hit Submit in the time before Retain auto deselects it does stick.

Same for other options.

Just takes a very quick mouse movement, by turning on Debug it gave me more time to click and submit.

I suspect that it is easier if I just edit the zigbee2MQTT config file.

I also tried it on my iPhone and the auto deselect is consistent across all three platforms.

I’ll test some other browsers on my Mac.

Anyone got any ideas on how to post a video of the issue here.

I have recorded a short video show ing how any zigbee2MQTT device setting is automatically deleted almost immediately after entering it.

I would really like to turn on Retain and QOS but the Home Assistant zigbee2MQTT implementation is automatically overriding me.

Is there a setting to get Home Assistant zigbee2MQTT to allow device setting changes?