Zigbee2Mqtt can't connect to conbee2

Hi all,
I could really do with some help on this.
I keep getting the following:

[services.d] done.
[08:44:50] INFO: Handing over control to Zigbee2mqtt Core ...
> [email protected] start
> node index.js
Zigbee2MQTT:error 2022-01-25 08:45:13: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-01-25 08:45:13: Failed to start zigbee
Zigbee2MQTT:error 2022-01-25 08:45:13: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2022-01-25 08:45:13: Exiting...
Zigbee2MQTT:error 2022-01-25 08:45:14: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:102:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:123:29)
    at Zigbee.start (/app/lib/zigbee.ts:58:27)
    at Controller.start (/app/lib/controller.ts:100:27)
    at start (/app/index.js:97:5)
[08:45:16] INFO: Handing over control to Zigbee2mqtt Core ...
> [email protected] start

I run homeassistant in a VM. I removed all config entries from deconz (although it’s still auto discovering). It’s almost as if it’s connecting to the wrong port, but i’m using the device id listed in the supervisor hardware section. Tried /dev/ttyACM0 as well as ACM1. Also tried using the direct device id (e.g. /dev/afafafafdeconz_etc.

No dice. Not sure what’s going on. Tried removing for 10 minutes, restarting, tried rebooting the host so it would reset the usb.

It worked fine on deconz. Only thing remaining is maybe the usb extension is too long and the signal weakens to much. I’ll try and plug it in directly. The other thing is maybe there are still remnants of deconz using this port and there is a serial port access issue ? Not sure how to remove deconz when it’s auto discovering stuff (i removed all the devices previously as to make new pairing easier).

Thanks for helping!

I guess deCONZ is still running and blocking the adapter.

You might be missing something in your config file. The below is from Supported Adapters | Zigbee2MQTT

1 Like

When i was testing with Z2M and a Conbee2 that indeed solved it for me but the feedback generally was that a CC2652 chip was better then the Conbee2 so i switched. But i can confirm Z2M works with Conbee2

1 Like

Tried that, still not working.

That’s my thinking as well. But a reboot didn’t fix it, so dunno what’s going on here. I just pulled the extension cable as well, also didn’t fix it.

When they say ‘configuration.yaml’ they mean the HA configuration right, not the zigbee2mqtt configuration.yaml in the config section?

No, the Zigbee2MQTT configuration.yaml

These are two different pieces of software.

Ok i’m stupid. I put it in the HA yaml previously :slight_smile:

Boom. Done. Thanks all.

> [email protected] start
> node index.js
Zigbee2MQTT:warn  2022-01-25 09:39:55: `permit_join` set to  `true` in configuration.yaml.
Zigbee2MQTT:warn  2022-01-25 09:39:55: Allowing new devices to join.
Zigbee2MQTT:warn  2022-01-25 09:39:55: Set `permit_join` to `false` once you joined all devices.
1 Like