Zigbee2mqtt - Can't pair new devices

Hey guys, I am currently trying to pair my new SONOFF devices via zigbee2mqtt to use them with HA. Sadly, I don’t know why, but I can’t pair devices anymore. I’ve already sent some devices back because I thought they are broken, but the new ones can also not be paired, so I think it might be a problem with my setup.

I think it must be something with zigbee2mqtt, because I don’t see any pairing messages in the logs for the new devices.

My new devices are:

These are the devices (all supported) I already have:

  • 7x Aqara Temperature/Humidity sensor
  • 1x Aqara vibration sensor
  • 1x Tint Müller Licht LED bulb
  • 1x Philips HUE smart switch

(is there maybe a limit of 10 devices!?)

Both devices are listed as “supported” by zigbee2mqtt.

My current setup looks like this:

  • Raspberry Pi 3B+
  • Raspbian OS
  • CC2531 Zigbee Stick (07/2020)
  • zigbee2mqtt (1.16.2, Commit: 05142044)

Here’s my zigbee2mqtt configuration:

homeassistant: true
permit_join: true
  base_topic: zigbee2mqtt
  server: 'mqtt://'
  user: [...]
  password: [...]
  port: /dev/ttyACM0
    - [...]
    - [...]
    - [...]
  [... 10 devices ...]

Isn’t there anyone who has the same problem or can at least tell me how to debug this?

Got the same issue. Got 5 devices connected for over a year now. Bought some new ones over the holidays, but can’t seem to be able to add any new device. Don’t see any message related to pairing in the logs.

Do your 2.4Ghz WiFi and Zigbee channels overlap? I think the default channel for zigbee2mqtt is 11, which overlaps with WiFi channel 1. If there’s overlap, your issues may be due to interference.

Hello. I had the same type of issue recently. Contacted the Z2M author and he recommended to reflash my cc2531. That did the trick.

Are you using Sonoff’s own firmware, or have flashed Tasmota on these devices?

I’ll look into that, however that solution seems unlikely, because all existing devices communicate fine without any issues.

It worked! Once I changed the channel & restarted, all known devices were gone. But I was once again able to add new devices. For the sake of it, I also tried to default channel (11), and that worked too. So looks like it has more to do with a reset than with the channel.

Sonoff’s own firmware. Haven’t tried Tasmota.

AFAIK Sonoff’s firmware depend on their cloud solution to work. Are you sure you can use MQTT with their firmware?

The documentation does not say anything about that zigbee2mqtt requires SONOFF devices to use Tasmota :thinking:

Only the Sonoff Wifi devices. The Sonoff Zigbee devices work out of the box with Zigbee2MQTT or Zigbee2Tasmota. Only pairing needed with a supported coordinator.

Regarding the wifi channel: My Wifi (2,4ghz) is configured to use channel 6, but there are three other Wifis (low signal strength!) that use channel 11.

I have two CC2531 sticks:

  • The first one has 10 connected devices (Aqara, Philips Hue, Tink) and works fine, but pairing does not work anymore.
  • The second one has 1 connected device (Philips Hue) and works fine.

Pairing the SONOFF devices does not work with any of these CC2531 sticks. There is nothing showing up in the logs. Really nothing. No “hey, this devices is unsupported” nor any warning or error. Nothing.

So you are using two coordinators ?
If so, does it mean that you have two independent Zigbee networks?

So you are using two coordinators ?

I set up the second one for testing. It is not online at the moment.

If so, does it mean that you have two independent Zigbee networks?

If both are online, what does “independent Zigbee networks” mean? You mean the network key? Both had different network keys, yes.

Each Zigbee network can only have one (1) coordinator.
As soon as you activate a second coordinator, you effectively establish a second independent Zigbee network. I’m not saying this is impossible or problematic, but it can be. So unless this is part of your network plan and you know what you are doing, I think your array of possible problems can be reduced if you avoid more electronic noise than needed.

As already mentioned, I’ve only used the second stick (+ separate zigbee2mqtt setup) for testing the pairing. It worked. That’s all I did so far with the second stick. It is not active at the moment.

I’ve noticed with my cc2530 that I need to physically power it off sometimes for it to accept new devices. It also depends which firmware you’re using on your coordinator as to how many devices it can accept. Looks like you have a couple of routers so you should be ok though.

1 Like

Ooooooookay, seems like everything is working again. I think turning the whole system off, waiting a few minutes and starting everything up again solved the problems :slight_smile: I was able to pair my SONOFF switch and my SONOFF temperature/humidity sensors!

Thanks for your help!

1 Like

Great, seems like the same issue as I have seen. I don’t think you even need to wait more than 5 seconds. It’s the power off that’s crucial.