Zigbee2MQTT doesn't detect some devices

I’m in the process of migrating a few dozen of Iris doors sensors and motion detectors from SmartThings to HA (Zigbee2MQTT/HAOS/SONOS Zigbee 3.0 USB stick).

I first unpaired them from SmartThings. 10 or so just appeared in the Zigbee2MQTT without me touching them and after 5 mins of interviewing they work fine. Several others took factory resetting, failed interviews, interview retries, but finally got correctly recognized and now work fine.

I’m down to 5 which won’t get detected by HA/Zigbee2MQTT no matter what. I’ve done factory resets, HA reboots, brought them close to the dongle, HA just doesn’t see them. I even fired up the old SmartThings hub and paired them there again (took 2 seconds) - they work fine. I unpaired again, and HA still pretends they don’t exist.

I spent 4 hrs on just these 5 sensors yesterday reading forums and trying solutions and I’m about to give up and use them via SmartThings integration.

Is there anything else I could try to make HA/Zigbee2MQTT to discover them?

What are the devices? Has Z2M detected any similar devices (same model type)?

1 Like

How many end-devices are paired with your coordinator now ?

1 Like

There are 18 devices currently. The devices which are failing are the same as ones which succeeded - Iris Door Sensor 3320-L. Ones which paired show as “supported”.

1 Like

Do you have any mains powered Zigbee devices ?

1 Like

4 GE bulbs and Iris plug (3210-L). All work fine. No change with bulbs on or off. I got the mains onboarded first.

Try to pair the remaining through a bulb or your plug

Choose it in the front-end

Interesting idea! Unfortunately it didn’t do the trick. I tried pairing via one bulb and then via another. It’s as if the device doesn’t exist. I’d think it’s broken, but when I fire up SmartThings hub it detects/pairs it in seconds.

I did another experiment:

  1. Removed one of the properly paired/working Iris sensor from HA and tried to add it back. It doesn’t detect it. I can’t add it back despite all resets and reboots.
  2. I plugged in another GE Zigbee bulb I haven’t used for years. HA detected it right away! Then I removed it, reset, and it rejoined right away as well.

So my Zigbee2MQTT pairing does work. But there is something about those 5 (now 6) Iris sensors which makes them invisible to HA, while they work without an issue with SmartThings.

Do you have a log in debug mode from Z2M while attempting the join?

I couldn’t spot any entries in the log related to trying to pair the devices. A ton of entries came up while resetting the sensor, but they were from other known devices.

I was finally able to add the remaining devices. Physically turning off the PC which runs HAAS and then turning it on again did the trick. I previously was triggering Proxmox host reboot via Proxmox UI which did help with similar problem with the Zwave JS UI devices. But Zigbee needed true power off.

Thanks all.

1 Like