Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)


#754

Hey,

I have messed up my settings etc and just want to do a fresh start with the zigbee2MQTT addon. How do i factory reset it? What files do i need to delete to make hass.io think that it is the first time suing the addon?

thanks


#755

Uninstall and delete the zigbee2mqtt folder in ‘share’


#756

hey, yeah thanks i thought that would have worked by itself but didnt! I also had to re flash my sniffer stick.


#757

How did you mess up? Asking to avoid doing it myself…


#758

Had a device that wouldn’t connect so I deleted the .dB file thinking it would refresh with the currently working devices. It didn’t and they stopped communicating with my stick. After a quick reflash everything worked fine again


#759

I’m seeing this error for unidentified EndDevice running v0.1.7 of the zigbee2mqtt addon.

zigbee2mqtt:info 2018-10-19 22:16:38 deck_door (0x00158d0001a67bfa): MCCGQ01LM - Xiaomi MiJia door & window contact sensor (EndDevice) 
zigbee2mqtt:info 2018-10-19 22:16:38 library_th (0x00158d0001a2df63): WSDCGQ01LM - Xiaomi MiJia temperature & humidity sensor (EndDevice) 
zigbee2mqtt:info 2018-10-19 22:16:38 dining_door (0x00158d00016c8103): unkown - undefined unknown (EndDevice) 
zigbee2mqtt:info 2018-10-19 22:16:38 main_th (0x00158d00015a0cf8): unkown - undefined unknown (EndDevice)

Does anyone have any ideas?
Also, is “unkown” a spelling mistake?
Thanks


#760

What are the devices? Are you sure they are officially supported?


#761

Hi, I started following this thread very early on and ordered all the hardware but never got around to doing anything with it. I remember there being a device limit but I can’t seem to find any details of this now? How many devices can be added? Many thanks :slight_smile: I’m looking forward to getting rid of my Xiaomi GW and getting some Tradfri bulbs in the near future! Thanks again


#762

I have been running zigbee2mqtt on a raspberry pi zero using the CC2531 as the coordinator. It was working well for devices that are fairly near it. I have some devices that I want to add upstairs which is a ways away from it and they are not working. So I purchased some sylvania smart+ plugs to use as routers. How do I make my devices connect to the router instead of directly to the coordinator? And how do I know that they successfully connected to the router? My devices are a bunch of xiaomi temp/humidity sensors, xiaomi door sensors and xiaomi motion sensors. Thanks for the help and the great project.


#763

Yes they’re supported. One is a MCCGQ01LM and the other is a WSDCGQ01LM. Interestingly, the first one of each type worked fine, after that the errors started occurring.


#764

Could use some advice. Trying to configure the Xiaomi cube.
He is triggering way to soon - so I try to add a seccond trigger

“battery”:“37.00”,“voltage”:2975,“linkquality”:81,“action”:“rotate_left”,“angle”:50.13"}

  - alias: cube1left
    hide_entity: true
    trigger:
      platform: mqtt
      topic: 'zigbee2mqtt/cube'
    condition:
      - condition: template
        value_template: "{{ 'rotate_left' == trigger.payload_json.action }}"

#      - condition: template
#        value_template: "{{ -40 < trigger.payload_json.angle }}"  nope

#       - condition: template
#         value_template: "{{ state_attr('trigger.payload_json.angle') < -40 }}" nope - HA dont start 
    action:
    - service: scene.turn_on
      entity_id: scene.sz_lesen

Buuuut… I dont get it with the seccond condition working
Somebody?


#765

I’ve been trying to pair CC2531 Routers to my coordinator without success. From what I understand, after flashing it, it enters pair mode automatically.

However for me, the red light just keeps blinking forever (every 1 second), and I get no pairing messages in the log.

I’m curious if I have to update the coordinator firmware too, although I can’t tell what firmware I have at the moment (it shows up as undefined in the log) and whether it’s necessary.


#766

Press S1 once.

Oh, sorry. You can’t even pair it. Did you tried to pair the router next (close) to the coördinator?


#767

Yeah, it’s right next to it.


#768

Try removing them several times each while new devices can’t join by sending mqtt message (see docs). Restart adding to make sure they aren’t connected and reconnect them. This worked for me


#769

That’s worked, thanks! I did discover that the CC2531 device also has a very short range compared to the Mijia hub, so that was also an issue. I’ve had to drop this solution till I find a workaround for the range issue :frowning:


#770

I bought these as routers. Plugged them in and repaired my sensors while next to them and linkqhality is so much better

Innr E27 Duo pack of 2 smart, warm white, dimmable, retrofit LED bulbs (Hue* & Alexa compatible) RB 165 https://www.amazon.co.uk/dp/B06XJ73XVR/ref=cm_sw_r_cp_apa_4OWYBbJFCQV44

They are only supported on the edge release at the moment. Will get full support on next update


#771

Hey
Iam have trying to join a DJT11LM vibration,tilt, fall for hours but it get alls the time .
Cannot get the Node Descriptor of the Device: 0x00158d0002a8cf4e (Error: Timed out after 10000 ms)

Iam standing beside the router when iam try to make it join.
I press until it led is steady then it blink twice. Thats how i pair all the other agara sensor. I have no problem to add other new devices afterwards
Please help me out.


#772

Keep pushing the button until it connects. Just like you do with Mija sensors. And keep it close to the coördinator.


#773

I had a similar issue with being unable to pair the router, and my coordinator firmware also reported as undefined. For me it was either due to having 23 devices already paired so no more could be added, or it was due to the older, undefined firmware.

In the end I flashed a spare CC2531 with the latest coordinator firmware and my router then paired with it ok…