Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)


#1304

In fact I have some troubles with my zigbee map now.

All devices work but they don’t show a connection in the map.
I can solve this by re-pairing the devices.
Do you think this could be avoided when setting ieee to retain?


#1305

I have exactly the same thing. Reflashed with the new controller, and I retained the IEEE.
The Zigbee devices work however… It´s just the map not showing the link and the signal strength.


#1306

No problem.

The flashing process is exactly the same as with the other devices (like the most common CC2531 stick, which I also have several of). The one difference is it uses a standard-pitch header (0.1 inch, if I’m not mistaken) rather than that mini header on the USB stick. So you don’t need the extra converter cable that’s needed for the CC2531.

You just need the XCore2530 module, the ZB502 motherboard, and the usual CC Debugger, which plugs right in.

All of the flashing commands are exactly the same, but you need to use the CC2530_CC2591 coordinator firmware.

I’m still super pleased with the performance. It’s an ugly pile of circuit boards, though, so I found an enclosure that fits it perfectly:

You’ll need to do your own drilling and cutting for the mounting standoffs and the antenna mount. Fortunately it’s soft enough aluminum that it’s pretty easy.

I’ll post a picture of the final “box” when it’s completely done.


#1307

Hi,

I’m running zigbee2mqtt on a raspberry pi zero w with a CC2531 as a coordinator. Now, I’d like to extend the network with an additional router. I’ve been reading this thread for a while and could not find the answer to my questions…

The idea is to use a CC2531 with the router firmware, but I have one doubt: does the CC2531 router should be connected to a new RPI with another instance of zigbee2mqtt, or just powered on by a USB adapter?

In case I need a new instance, what should be on the configuration.yaml to tell the stick it is a router?

thanks


#1308

Just needs powered by a USB adapter.


#1309

Will not that only solve the problem in case I had used z2m to activate bulb in the past session/run?


#1310

Don’t think so. I have set ieee to retain and also don’t have correct corrections in the map.
My Xiaomi sensors for example are not connected in the map, but they work fine.

Looks like there are still some issues with the map, but as long as all devices are working fine I wouldn’t bother about that.


#1311

Did someone here update to the newest firmware and still have the connections visible in the zigbee map?


#1313

Alright,

so i have just reveived and installed an iCasa Zigbee 3.0 Dimmer (ICZB-IW11D). Great Dimmer! Working fine. Dims LED bulbs without buzzing or flickering. Perfect… but there is one little thing that i discovered.
The dimmer doesn’t seem to give any feedback when it being operated (on/ off/ brightness) neither by the buttons on the dimmer or by an external switch connected to it. And second, it appears to be offline al the time when i look in network map.

Is this due to the hardware or is it because it’s not fully supported by z2m yet?

image


#1314

Hi all.
I attempting to move my HA system from raspberri py to virtual environment hoping my installation will be more stable.
I am running Hassbian in VM on debian 9.8.0
For some reason that i don’t understand my zigbee2mqtt is not working
in get this permission error and i have no idea on how to fix it.

[email protected]:~$ sudo systemctl status zigbee2mqtt
zigbee2mqtt.service - zigbee2mqtt
Loaded: loaded (/etc/systemd/system/zigbee2mqtt.service; disabled; vendor preset: enabled)
Active: active (running) since Fri 2019-02-22 21:31:58 EET; 1min 11s ago
Main PID: 414 (npm)
Tasks: 23 (limit: 4915)
CGroup: /system.slice/zigbee2mqtt.service
├─414 npm
├─428 sh -c node index.js
└─429 node index.js

Feb 22 21:32:00 debian-HA npm[414]: > node index.js
Feb 22 21:32:02 debian-HA npm[414]:   zigbee2mqtt:info 2/22/2019, 9:32:02 PM Logging to directory: '/opt/zigbee2mqtt/data/log/2019-02-22.21-32-02'
Feb 22 21:32:03 debian-HA npm[414]:   zigbee2mqtt:info 2/22/2019, 9:32:03 PM Starting zigbee2mqtt version 1.1.1 (commit #92d88b6)
Feb 22 21:32:03 debian-HA npm[414]:   zigbee2mqtt:info 2/22/2019, 9:32:03 PM Starting zigbee-shepherd
Feb 22 21:32:03 debian-HA npm[414]:   zigbee2mqtt:info 2/22/2019, 9:32:03 PM Error while starting zigbee-shepherd, attemping to fix... (takes 60 seconds)
Feb 22 21:33:03 debian-HA npm[414]:   zigbee2mqtt:info 2/22/2019, 9:33:03 PM Starting zigbee-shepherd
Feb 22 21:33:03 debian-HA npm[414]:   zigbee2mqtt:error 2/22/2019, 9:33:03 PM Error while starting zigbee-shepherd!
Feb 22 21:33:03 debian-HA npm[414]:   zigbee2mqtt:error 2/22/2019, 9:33:03 PM Press the reset button on the stick (the one closest to the USB) and start again
Feb 22 21:33:03 debian-HA npm[414]:   zigbee2mqtt:error 2/22/2019, 9:33:03 PM Failed to start
Feb 22 21:33:03 debian-HA npm[414]:         {"message":"Error: Permission denied, cannot open /dev/ttyACM0","stack":"Error: Error: Permission denied, cannot open /dev/ttyACM0"}

[email protected]:~$ ls -l /dev/ttyACM0
crw-rw---- 1 root dialout 166, 0 Feb 22 21:31 /dev/ttyACM0

If i go in to the directory and start npm it starts and finds the USB sniffer and it works fine.

If anyone has an idea on how to fix this is quite appreciated.
Thanks


#1315

Possibly the user that systemctl is starting npm with is different user to the one when you do it manually.


#1316

Thanks for your response it should be the same user since i have only 2 users (homeassistant, xxxxx, and root)
Just went to the dev/ttyACM0 and the owner is root and is part of a group : dialout
Will play with that and see what happens.
Thanks again


#1317

What user are you when npm started manually?

What user does your systemctl file specify?


#1318

Thnaks Nick for your response
Is the same user the user that i setup when i installed debian is adifoto the same user is in the /etc/systemd/system/zigbee2mqtt.service
So it make no sense why i get permission denied


#1319

make sure the user is in the dialout group.


#1320

i just moved the ttyACM0 in root without success.
sorry for my beginner’s question how do i add the user to the dialout group?
And can a user be in more than one group? Is part of the sudo group, can you point me to some info please?
Thanks again for your help.


#1321
usermod -aG dialout adifoto

#1322

Did you follow the instructions in the error message already?

Remove the zigbee2mqtt usb stick. Press the button closest to the usb connection. Reinsert the stick. The green on the stick should come on. Restart the zigbee2mqtt addon. The green light should go off for a little while and then come back on.

Edit: Never mind. I see you’re not running hassio.


#1323

yes i am on hassbian
thanks


#1324

in the log i have this error now:

2/22/2019, 10:56:32 PM - info: Error while starting zigbee-shepherd, attemping to fix... (takes 60 seconds)
2/22/2019, 10:57:33 PM - info: Starting zigbee-shepherd
2/22/2019, 10:57:36 PM - error: Error while starting zigbee-shepherd!
2/22/2019, 10:57:36 PM - error: Press the reset button on the stick (the one closest to the USB) and start again
2/22/2019, 10:57:36 PM - error: Failed to start Error: request timeout
at CcZnp.<anonymous> (/opt/zigbee2mqtt/node_modules/cc-znp/lib/ccznp.js:255:22)
at Object.onceWrapper (events.js:277:13)
at CcZnp.emit (events.js:189:13)
at Timeout.<anonymous> (/opt/zigbee2mqtt/node_modules/cc-znp/lib/ccznp.js:234:18)
at ontimeout (timers.js:436:11)
at tryOnTimeout (timers.js:300:5)
at listOnTimeout (timers.js:263:5)
at Timer.processTimers (timers.js:223:10)

So i manage to fix it by changing the permissions for ```
ccznp.js

Thanks nickrout for all your help.