[zigbee2mqtt] Instability due to restart/reboot after pluging an additional USB device


I’m running HA (hass.io) on a debian Proxmox VM. The CC2531 dongle is passed through to the VM.
My zigbee network is composed of a dozen of routers (Ikea smart plugs and bulbs, Xiaomi bulbs) and a dozen of different types of sensors. Everything worked like a charm.

Some days ago, here is what I did:

  • Shutdown the VM through HA web interface
  • Connected a new USB device (FTDI to flash ESP32 devices)
  • Enabled the USB pass-through for this USB device in the VM config via Proxmox interface
  • Started VM. The CC2531 didn’t change his path (still /dev/ttyUSB0)
  • Tried to flash my ESP32, it didn’t work
  • Shutdown the VM through HA web interface
  • Unplugged the FTDI
  • Verified the USB devices configuration for the VM
  • Started VM

After this, my zigbee devices didn’t respond at all. I tried to generate a map a the network, every devices was disconnected (lots of timeout errors in zigbee2mqtt logs).
I managed to reconnect some devices by powering them off and on.

Later, everything was connected back on the map, but I encounter instabilities. For example, I have to try several times to switch some lights on/off.

Would someone have a solution for me ?
Thank you for our help !

Finally I moved zigbee2mqtt to a dedicated raspberry pi then updated everything (CC2531 firmware and zigbee2mqtt container). It works smoothly now :slight_smile: