Zigbee2mqtt last_seen

Does anyone have a definitive guide to how to enable the last_seen attribute of a device in Zigbee2mqtt?

I’ve read numerous posts that say “oh just add this, or just add that”



As far as I can tell, that would set the date and time format to local time for the last_seen attribute :man_shrugging:, but how does that then enable it and where specifically does this need to be added?

I enabled simple availability in my Zigbee2mqtt and now have all my devices showing their availability:

I look at the first device and the last_seen attribute shows N/A

Then I discover this under Settings > Raw

How do I change that "last_seen": "disable", to "last_seen": "enable",

I can’t see that in the zigbee2mqtt configuration.yaml file


Try restarting Zigbee2MQTT. If it is still not enabled for all your devices, I’m afraid you will need to re-pair them.