Zigbee2mqtt moes switch problem

Hello! I’m kinda new to the HA community. I have a problem with my Zigbee switch. I’m using Home Assistant with zigbee2mqtt add-on and CC2531 receiver. I have moes neutral/no neutral switches, 2 and 3 gang version. 3 gang works great without any issue. However, my other 2 gang switches misbehave. Zigbee2mqtt discovered them as TS0012 model. Whenever I switch on/off one of the switches (left or right) the other side activates/deactivates too. When I switch on left side, the right one switches on too after around half a second. When I switch the right side on, the left one switches on too immidiately. I can’t power on or off only one side of the switch. How can I debug the issue?

These are the switches I’m using:

I have moes switch and I believe it has nothing to to with z2m. Check your wiring first.
If wiring is oke than the only way for this to happen is if you configured it to behave like that.

Wiring is ok. I connected them just like the 3-gang version. Both 2-gang versions behave that strange way exactly after pairing them to the zigbee network. No configuration to them has been made.

Even when I send mqtt payload to switch only left or right side ON, the other side fires on too.

It seems to me that your switch is saw by ha as one gang and not two gang switch. Try simple solution first. Remove it from z2m and pair it again.

I did it many times without a success.

Z2M description of those switches shows as “Smart light switch - 2 gang”.

Maybe a stupid question. But did you tried to switch them on in z2m web ui?

Yes. Same thing happens.

When switching one side in web ui, the other one fires too almost immidiately.

I don’t know. This doesn’t make any sense. I have two way gang wifi and zigbee switches but that never happened.

I even tried them on my friend’s HA. Same thing is happening there too. Are your switches also recognised as “TS0012” model?

Yes but they are sold by bseed brand.

Hmm, I don’t understand their behaviour then. 3-gang version works perfectly fine.

Well or switches are bad from the factory, it happened to me, or you messed up wiring.

Seems to be a faulty switch. Have you tried to (factory-)reset it?

Both switches could be faulty at the same time? How can I perform the factory reset?

Usually press 1st. (left) rocker to on, then hold that rocker for ~5 seconds.

Also make sure the lights connected are not some cheap 7 watts LEDs, especially if you have no neutral line going to the switch. If you got capacitors with those switches try to install one between L1 and N close to the LED.

They work without capacitor. Tested on different led bulbs.