Zigbee2mqtt not finding USB stick

I’ve had my HA set up for over a year now with Zigbee2Mqtt working fine on a CC2531 stick.
However in the last couple of months my HA would seem to die for no reason in that i couldn’t access the HA webpage and no automations would work. I also noticed that occasionally my zigbee network would just stop working.

As such i looked at the Zigbee2mqtt logs and had a message about it noting being able to connect to the adaptor.
As such i looked online at found that it might be because the firmware on the CC2531 is becoming corrupt. As such i flashed a new firmware on another CC2531 stick and plugged it in. This seemed to work fine but i noticed that my Zigbee2mqtt version was old (was on 1.18) and from looking at it the respotrity for it had change. As such i added the new version and now have it on 1.23. In this process i lost all my zigbee devices but reconnected them all with no issues and it seemed to be working perfectly again.

However about a day later all my Zigbee devices had stopped working again and when i look in the logs i have the below error messages

Zigbee2MQTT:error 2022-02-27 13:00:34: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-02-27 13:00:34: Failed to start zigbee
Zigbee2MQTT:error 2022-02-27 13:00:34: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2022-02-27 13:00:34: Exiting...
Zigbee2MQTT:error 2022-02-27 13:00:35: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:102:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:123:29)
    at Zigbee.start (/app/lib/zigbee.ts:58:27)
    at Controller.start (/app/lib/controller.ts:100:27)
    at start (/app/index.js:101:5)

I did some more research that this might be because of the power draw of the CC2531 so i brought a powered USB hub but still have the same issue.
When i first started having this issue it would only sometimes not work and now it is all the time.

Has anyone got any ideas as I find it odd that it’s been rocksteady for over a year but suddenly i’m having these problems.

I’ve still got the same number of zigbee devices (6 in total) and I can’t think of anything that would have changed to affect it

i suppose your adapter setting is: /dev/tty*
try: by-id
Adapter settings | Zigbee2MQTT
the command:

ls -l /dev/serial/by-id

and show us plz, your configuration.yaml

1 Like

It is by-id and this is the config for my zigbee2mqtt intergration

data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
  base_topic: zigbee2mqtt
  server: mqtt://xxx.xxx.xxx.xxx
  password: XXXX
  port: >-
  log_level: warn
  pan_id: 6754
  channel: 11
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
  port: 8099
experimental: {}
availability: false
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: '-d -d'
  log: false

In my zigbe2mqtt I use

port: /dev/ttyUSB0

although my id is


Everything is working fine. Sometimes I get errors on pinging some light switches but they are working fine. I don’t know why this error is showing. It might have something to do with sonoff smart plugs but i’m not sure.
Anyway try to use just usb port.

I’ve tried that and it still doesn’t work

about your docker-compose?

privileged: true
  - /dev/serial/by-id/usb*
#and try 
# - /dev/serial/by-id:/dev/serial/by-id 

Try simple things. Change usb port, change usb cable if you are using one, if not, buy one.

could you modify your zigbee2mqtt.yaml:

  port: /dev/serial/by-id/usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B0014D98FE9-if00


look here:

  port: /dev/ttyACM0
  adapter: deconz

You have also add your adapter in the config.yaml from zigbee2mqtt, do it not in your cifiguration.yaml.
Please look for your adapter!


If I try that it automatically changes it to the below when I save it

  port: >-

And then i still have the same issue

I’m sorry but i don’t understand what you mean.

All the changes i’m making are in the config settings for Zigbee2mqtt


i mean you have to add the line:

 adapter: [your_adapter] 


Ahh sorry.

Right i’ve done that and it crashed HA first time round but seems to have started up ok now. I’ll see how long it lasts

Z2M suddenly didn’t work anymore after an update this morning. Your post cleared it up and everything is working again. Thank you so much!