Zigbee2mqtt not recognizing device

So, i had a Wled setup with a Wemos d1 mini.
I have had trouble before with the wemos losing connection. I was fed up. and i bought a led driver from ali express… read comments of people succesfully adding it to zigbee2mqtt.
So i received it, and tried adding it to my ZHA coordinator.
It was added without issues, but i had little options.
So i thought oke, lets remove it and add it to Zigbee2mqtt.
Yes i have both coordinators running side by side. some devices run better on ZHA and the other way around as you might know. Most devices run best for me on ZHA so thats why i started there.
Now when i try to add my device to zigbee2mqtt, it will not find my device. I made sure i allowed new applications for devices. but its not seeing a device.
Once i open ZHA and click add device. right away i see the device being added. so the device is in the right mode, you would think.
I have removed the device from ZHA, and then unplugged the ZHA coordinator. so it will not connect to ZHA.
But still no luck.
Im running out of options, Why is my Zigbee2mqtt not seeing this device??

Hoping someone has the solution im not seeing.

Thanks in advance!!

What is the model of the device? Z2M may just not support (however, it should still find it). Do you see anything in the Z2M logs when you are trying to pair the device?


This is the device, and since i litteraly read, that someone has added it to Zigbee2mqtt. and not ZHA, it should at least see the device

Ahhhh, it’s a Gledopto. They are GREAT devices, but finicky at times. I have a couple that I had to put into pairing mode 3 or 4 times before Z2M picked them up.

Is there anything in the logs when you put Z2M into pairing mode? Any errors or anything like that?

hmm, could be that, but when looking at the Zigbee2mqtt logs, nothing is happening, its just saying: Zigbee: allowing new devices to join.
Nothing after that

No traffic at all? :thinking: That’s suspicious. How many devices do you have on Z2M? My instance is constantly sending traffic to my MQTT broker.

I had a similar problem trying to add an Aqara P1 motion sensor to Z2M. Despite replacing batteries and trying the sensor in multiple rooms I could not get any response from Z2M, and for a time thought the sensor had been damaged in transit. While looking for any possible solutions for this problem I found one that worked.

The solution was to change the ‘Permit Join’ option from ‘All’ to a a signee router device. The post I found on Reddit suggested a Philips Hue bulb. Luckily I have several Philips Hue bulbs connected to Z2M, so I changed the ‘Permit Join’ option to one that was in the room where the sensor would be placed (see screenshot below).

Much to my surprise the motion sensor connected within seconds and was correctly identified by Z2M. After all of the failed attempts previously I did not expect it to work. However, after joining the sensor has worked flawlessly for weeks now without error.

I’m not sure if my problem was the same issue you are facing but it does appear to be similar. I hope the solution I found for my Aqara sensor helps you.

Thanks, i have tried letting it join via a different device, i only have 1 precense sensor in zigbee2mqtt, and about 46 in ZHA. so i tried adding via this sensor but no luck unfortunatly.

Yess, thank you, i have kept trying to add it using my precense sensor. And all of the sudden it worked!!

Thanks for the help, much appreciated