Zigbee2MQTT ...not running

Hi…i do have a problem with my Zigbee2Mqtt setup.

I have a Skyconnect adapter and installed the brooker and zigbee2mqtt.

I think i have verything set up correctly but somehow it is not starting .
first of all, like in all other addons…i cannot see the CPU usage

Thats my configuartion:

Log is actually very long and in the end it shows that Zigbee2Mqtt is started

even on my MQTT i can see that it is running

but when i open my Zigbee2mqtt on the sidebar…it is never starting…

i dont have any idea anymore…

i deleted already all files, even the Zigbee2Mqtt configuration

no changes

can you help???

thank you very much


How does the configuration.yaml (in the zigbee2mqtt folder) look like?

hope that can help

homeassistant: true
- 236
- 220
- 181
- 239
- 72
- 56
- 0
- 77
- 44
- 210
- 51
- 24
- 139
- 196
- 69
- 169
pan_id: 12987
- 143
- 79
- 86
- 166
- 250
- 174
- 128
- 153
homeassistant_legacy_entity_attributes: false
legacy_api: false
legacy_availability_payload: false
server: mqtt://core-mosquitto:1883
user: addons
password: iequ9oophe8too9eer1xahpo5iej5zei5aizie6au4aiDieghidaey9bi7eeLohR
port: >-
adapter: ezsp
port: 8099
legacy: false

You should format the code correctly for easier readability, and you should never share passwords (even if this is “just” zigbee2mqtt) Have you tried uninstalling and reinstalling the addon? Here is my configuration.yaml that you can compare with.

  - devices.yaml
  - groups.yaml
homeassistant: true
permit_join: false
  base_topic: zigbee2mqtt
  user: addons
  password: redacted
  server: mqtt://core-mosquitto:1883
  port: tcp://
  baudrate: 115200
  disable_led: false
  transmit_power: 20
  log_level: warn
  pan_id: 6753
  channel: 20
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
  last_seen: ISO_8601_local
    app_name: Zigbee2MQTT
    eol: /n
    host: localhost
    localhost: localhost
    path: /dev/log
    pid: process.pid
    port: 514
    protocol: udp4
    type: '5424'
device_options: {}
blocklist: []
passlist: []
queue: {}
  port: 8099
experimental: {}
availability: false
  ikea_ota_use_test_url: true

I dont have anything written in my Configuation.yaml about MQTT
my configuration looks much more different.
My mosquito broker is working, its somehow the Z2M that doesnt start .

You posted the correct file earlier. Take note that there are two configuration.yaml, one for home assistant and one for z2m (under the zigbee2mqtt folder).

There are 2 configuration.yaml files…the MAIN one is in the home assistant folder and it for home assistant, there is a separate folder called zigbee2mqtt, inside that folder is the configuration.yaml file that is specific to zigbee2mqtt.

i saw that, but still…i have no idea why my z2m is not starting

Have you tried uninstalling / installing the addon? Do a backup first to be safe.

i did already…a few times

The only other thing I can think of is your browser is caching old content…you could either clear your cache, force refresh by holding down Ctrl F5 and hard reload page, or try another browser

It would save some time if you wrote what troubleshooting you already have done.
Do you have several instances of Z2M installed by any change? A edge version or something?

no…just that one

Try renaming the file and restart, it should generate a new default one.

I deleted al the files and un-installed z2m

Installed it again and I saw a new file generated.

The problem is… The z2m app is not starting… I never get a green dot and the CPU load shown

When I go to the integration page… I see it under the MQTT integartion

But the app never really started and I can’t see the lovelace page…

At the log… It’s written… Z2m started

You’ve tried another browser?