Zigbee2mqtt not starting...but still running ok!

I have had HA and Zigbee2mqtt running for several years now. Few years ago I switched to ZZH! stick and have been very happy with it.
Few days ago I tried to add a new Zigbee-device, but was unable to do so. It turned out I had very old version of zigbee2mqtt Add-On installed (1.18.1-1 something), and apparently there had been a repository change or similar at that version number, so my zigbee2mqtt hadn’t received any updates after that.
I found instructions to just uninstall old 1.18 and point to a new repository to download latest version. I did so, but now looking back I forgot to copy all the settings/config from the 1.18, so my new 1.28. version didn’t start. It was late night and I didn’t feel like debugging, so I thought to restore my setup from a 3-day old snapshot and come back to the problem the next day.

Now I’m not sure what actions I did take in order to make my zigbee2mqtt function again, because I had try all kinds of tricks. Uninstalling Add-On, reinstalling, rebooting ect. All I know is I did NOT touch the configuration, and I didn’t modify any files on disk (by writing/deleting). The zigbee2mqtt eventually started to work, but “without the add-on starting itself”. It’s very weird, I can’t start the Add-On, but all my zigbee sensors and devices are updating. Here’s the log:

And here’s the front page:

If I click on the sidebar “Zigbee2MQTT”:


What’s wrong with my setup and how to fix it?

After restoring a snapshot I am having the exact same issue - addon not started but devices are up and running and I am seeing everything updating from the addon logs!

I managed to go around it by removing the addon, removing the addon folder, deleting the whole home-assistant_v2.db and after that - restarting and installing the addon again. Pretty sure that the db part actually resolved the problem.

Hey, I actually solved the issue with the same method as you - deleting the db and reinstalling.

1 Like

I am having this same issue. After uninstalling the add-on, removing the folder and database, and reinstalling the add-on, did you have to re-add all of your Zigbee devices or did they just show up?

If I remember correctly, I ‘maybe’ had to rename them again, but did not have to re-pair

Unfortunately I had to repair them, took me an hour. I copied the backup list of devices from the zigbee2mqtt folder and renamed them after that quickly

Had the same issue, zigbee devices were working fine but addon wasn’t “started”. Happened after a restore. Rebooting the entire host solved it.

had the same problem, restartet HAOS from proxmox, and it solved it

I’ve had the same problem some times. My system is running on virtual machine at Synology NAS.
Reboot usually don’t help. I usually shut down the virtual machine, and restart it.