Zigbee2MQTT not starting , tips needed to find rootcause/solution

HI all, I started with ZHA intergration with my sonoff zigbee dongle with some ecodim dimmer. But after some weeks the dimmers stopped working. I found online that these dimmer are actually not working with ZHA therefore I am trying to go to zigbee2mqtt but I keep having problems. And I am not sure what to try/do to found out a way to make it work.
If anyone has any tips

What I have done

  • I flashed the Sonoff zigbee 3.o usb dongle plus following the video:
    Update the Sonoff Zigbee Dongle-E Easily - How To - YouTube (twice since it still didn’t work after first try)
    I used the files “ncp-uart-sw_v6.10.3_115200.gbl” and “nvm3_initfile.gbl” from
    github from this video.
  • Installed mosquito broker and kept the default values
  • Installed zigbee2mqtt and later on zigbee2mqtt EDGE
  • I disabled and later on deleted ZHA. It is discovering the usb dongle, so somehow the usb is
    visible for zha.
  • I checked if I have write access to the port (which I have)
  • Put de dongle in different usb-ports. Also I have an usb splitter and tried that one. Even after
    restarting a million times.
  • Added the following in my “/config/configuration.yaml” serial:
    adapter: ezsp
  • Have the following in “/config/zigbee2mqtt/configuration.yaml”
    homeassistant: true

Below are my settings of my mosquito broker (not sure if that can be an issue), of my zigbee2mqtt and a picture of the hardware (for the port).
And the log message can be found here error log zigbee2mqtt - Pastebin.com

Any tips/help is appreciated.

Furthermore, a side question If I cannot solve this issue would it work if I buy a new usb dongle (from a different brand) or will I get into the same problems?

System version
Home Assistant 2023.5.2
Supervisor 2023.04.1
Operating System 10.1
Mosquitto broker: 6.2.1
Zigbee2MQTT: 1.30.4-1
Zigbee2MQTT Edge: version not mentioned but installed 11th may 2023

settings of mosquito broker (defautls)

logins: []
require_certificate: false
certfile: fullchain.pem
keyfile: privkey.pem
active: false
folder: mosquitto

Settings zigbee2mqtt (EDGE)

data_path: /config/zigbee2mqtt
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: false
  base_topic: zigbee2mqtt
  server: mqtt://core-mosquitto:1883
  user: Mqqt_person
  password: *************
  port: /dev/ttyACM0

harware info

Please format your post so we can read it.

2023-05-11T12:46:45.563Z zigbee-herdsman:adapter Failed to validate path: 'Error: spawn udevadm ENOENT'

It can’t find /dev/ttyACM0

Both, at the same time? You only have one “dongle” (coordinator) so you can only use one of them at a time.

Thanks for your responds and I have edited the post to make it readable.

I solved the issue thanks to you. I look online what I could do with the port. Instead of using ‘dev/ttyACM0’ as a port I used the "devlink’ find under hardware.

  port: /dev/serial/by-id/usb-ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2_20230221152857-if00
   adapter: ezsp